How to integrate activiti in Grails 2.4.4

cancel
Showing results for 
Search instead for 
Did you mean: 
Active Member II

How to integrate activiti in Grails 2.4.4

Dear team,

I am implementing activiti in grails 2.4.4 version.I am new to this implementing activit in grails framework.

i am added these plugins in BuildConfig.groovy

compile ":activiti:5.12.1"
compile ":activiti-spring-security:0.5.0"

but i am getting error like this

Command terminated with an exception: org.grails.ide.eclipse.longrunning.client.GrailsProcessDiedException: Grails process died (see details for partial output)
Grails process died
------System.out:-----------
Loading Grails 2.4.4
|Configuring classpath
Error |
Resolve error obtaining dependencies: The following artifacts could not be resolved: org.activiti:activiti-engine:jar:5.12.1, org.activiti:activiti-spring:jar:5.12.1: Could not find artifact org.activiti:activiti-engine:jar:5.12.1 in grailsCentral (https://repo.grails.org/grails/plugins) (Use --stacktrace to see the full trace)
Error |
Resolve error obtaining dependencies: The following artifacts could not be resolved: org.activiti:activiti-engine:jar:5.12.1, org.activiti:activiti-spring:jar:5.12.1: Could not find artifact org.activiti:activiti-engine:jar:5.12.1 in grailsCentral (https://repo.grails.org/grails/plugins) (Use --stacktrace to see the full trace)
Error |
Resolve error obtaining dependencies: Could not find artifact org.activiti:activiti-engine:jar:5.12.1 in grailsCentral (https://repo.grails.org/grails/plugins) (Use --stacktrace to see the full trace)
Error |
Could not find artifact org.activiti:activiti-engine:jar:5.12.1 in grailsCentral (https://repo.grails.org/grails/plugins)
|Run 'grails dependency-report' for further information.
------System.err:-----------
Starting process on DESKTOP-L6ILG2D/192.168.10.2

Could you please give the support to me.

Thanks&Regards,

V.HimaBindu

1 Reply
Active Member II

Re: How to integrate activiti in Grails 2.4.4

I am Added this line in Config.grrovy

compile "org.activiti:activiti-spring:jar:5.22.0"

after refresh the dependencies , it's working fine