How to solve NoSuchMethodError when i'm calling webservice from workflow?

cancel
Showing results for 
Search instead for 
Did you mean: 
Member II

Re: How to solve NoSuchMethodError when i'm calling webservice from workflow?

Hi

I'm reffering to Alfresco BPM (Activiti)

Thanks 

Jakub

Established Member II

Re: How to solve NoSuchMethodError when i'm calling webservice from workflow?

Hi Jakub Rautner ,

I'm a bit confused. You said it works fine for you so I thought you were able to call web service successfully in Activiti context. 

There's nothing I can do to help you unless you can share a unit test that demonstrates this issue. In your unit test, it needs to demonstrate how web service is called and the fact that geronimo-jaxws_2.1_spec-1.0.jar is being used. 

I believe it is a basic programming task to solve library conflict issue like this. This issue seems not a problem with Activiti but rather a problem with how you implement your web service call in your process. 

Hope I make sense,

Thanks,

Thong Huynh

#bp3

Member II

Re: How to solve NoSuchMethodError when i'm calling webservice from workflow?

Hi Thong Huynh

i'm able to call webservice and it's works outside of activiti. I think it s probably problem with implementation of ws ... not with its call. 

I try to explain it. I'm using cxf-codegen-plugin to generate java classes from wsdl file. There is class that extends javax.xml.ws.Service class. Outside of alfresco declaration of this class is from default jdk of project. In alfresco repo project declaration of this class is in geronimo jar and i have no influence to change that. Sorry if its out of your area but i have no clue how to solve it.

It's not problem to write unit test for this case but i m not sure if i can published that concrete webservice to public network. 

Thank you for your time

Jakub

 

Established Member II

Re: How to solve NoSuchMethodError when i'm calling webservice from workflow?

Hi  ,

No worries. Happy to help.

Your unit test doesn't have to work with your webservice. You can try the public ones like I did. Web service is web service. They are the same. If your unit test works with the public ones but not with your web service then it's likely your own web service has some problem. 

Thanks,

Thong