Installing Alfresco Process Services Trial using an Installer

cancel
Showing results for 
Search instead for 
Did you mean: 

Installing Alfresco Process Services Trial using an Installer

Moderator
Moderator
2 5 2,140

Thanks for evaluating Alfresco Process Services!

Here are the steps to installing and launching the trial version:

 

1. Download Software and License Key

 

If you have registered for the 30 day trial you should have received an email similar to the one below.

 

Trial email

Trial Email

 

To get up and running quickly, I would recommend to download one of the three installers (depending on your operating system). Download the 30-day trial license file since you will need it to start the product.

 

2. Install Alfresco Process Services using installer

If you have chosen one of the installers (for Windows, MacOS or Linux) the installation application will include everything you need to get up and running. It uses h2 database along with tomcat server. 

Unpack the downloaded zip file and run the installer. I am running on MacOS so my file was called alfresco-process-services-1.6.0-osx-installer.dmg. Installation is simple, the only options you have to select is where to install the application.

 

By default the installer is installing in /Applications/alfresco/process-services (on MacOS).

 

MacOSInstaller

  

The last dialog box will give you the URL’s and default admin account that you will need to access the application.

 

Login details

Application URL’s and Login Details

 

If you prefer to install Alfresco Process Services using the .war file please follow instructions here

3. Apply the License Key

 

The next task is to apply the licensee key. Copy the activiti.lic (downloaded earlier) to the folder [Installation Folder]/tomcat/lib

 

License key

License Key Location

 

4. Start Alfresco Process Services App

 

Select the [Installation Folder]/StartProcessServices.app. This will start up the Tomcat application server and the Alfresco Process Services server. When you see the message Server startup in XX ms in the log the server is ready for you to login in.

 

 

Alfresco Process Services Startup Application

 

5. Login to Alfresco Process Services

 

Once the server has started login to Alfresco Process Services. The default application URL is http://localhost:8080/activiti-app with a user ID of admin@app.activiti.com and a default password of admin.


Login page

Alfresco Process Services Login Screen

 

Once you login you should see the user dashboard. This has the default apps loaded:

 

  • App Designer - For business & technical power users (involved in building solutions) to graphically design process models, web forms, DMN decision tables, data models, custom stencils, process apps and share them with others.
  • Task App - Out-of-the-box UI for end-users to manage tasks, cases and start new processes
  • Identity Management - This app is only available if you are an administrator. This is where administrators manage tenants, users, capabilities, organization, and personal information. For example, administrators can define which Apps users will be able to access and see on their home page depending on their role.
  • Analytics App - This app includes standard analytic reports and users can also configure custom reports for performance and throughput statistics of your processes.

 

App Designer

Alfresco Process Services Home


 

I have recorded a video showing the whole installation and startup process. I hope you found this post useful.

5 Comments
maayanl
Active Member II

Hi,

I followed all steps and when I arrived to step 5 : Login to Alfresco Process Services -

I surf to :

 http://localhost:8080/activiti-app (I didn't changed the default port)

And I got nothing. Empty page: 

Do you know to tell me why?

Thanks.

Moderator
Moderator

Hi maayan,

Please check the catalina.out log file of the tomcat to understand why.

I hope this will help you.

maayanl
Active Member II

Hi,
Thanks for your quick answer.
I looked into catalina.#DATE#.log and no errors appear. After the message of:
"start Server startup in 2280 ms" - no more lines.
Any other Ideas?

Moderator
Moderator

Did you restart the server after the installation?
Please double check the catalina.out (also at the very beginning) it looks very strange without any notification.

maayanl
Active Member II

I attached My Catalina log to my question in Alfresco-Comunity:
https://community.alfresco.com/message/821209-cannot-see-login-screen-in-alfresco-activiti-trail

If you don't mind to take a short look in the log and see if I missed something.

Thanks alot for your help!