oracle12cDialect not supporting APS ?

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member

oracle12cDialect not supporting APS ?

 I have created one extension (jar ) for rest services . In that Jar i am using org.hibernate.dialect.Oracle12cDialect for oracle . but APS is not running .throwing error "* Oracle12cDialect class not available*"

3 Replies
Highlighted
Alfresco Employee

Re: oracle12cDialect not supporting APS ?

The version of Hibernate used in APS is old and doesn't contain that dialect.

Highlighted
Active Member

Re: oracle12cDialect not supporting APS ?

I want to use Identity Generator In hibernate . But Its available in 12C Dialect .there is any way to Generate Identity?

Highlighted
Alfresco Employee

Re: oracle12cDialect not supporting APS ?

I don't think there is another way to use the 12C dialect without using the new hibernate libs. You can try to use them but at your own risk since they haven't been tested.

APS also uses hibernate Identity generation with the old libs.