Process Instance name has no default value ?

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
ppcchh
Active Member

Process Instance name has no default value ?

Hello,

I have a pretty straight forward question. Is it considered as normal that process instance names are not persisted and not returned on an API call such Get a process instance OR Get a historic process instance, although a field NAME_ is present in ACT_HI_PROCINST  ?

I was expecting a process instance to be default named according the name declared in the BPMN definition.

<process id="simple-approval" name="My Process Instance Name" isExecutable="true">

...

</process>

By searching some similar problem i found this Process instance name is never persisted in table ACT_HI_PROCINST(for HistoricProcessInstance) · Iss... 

But from what I can see it has not been fixed, or am I missing something ?

Thanks !

Stephane

PS : I launch my processes by submitting forms, using activiti 5.22.0.

3 Replies
gdharley
Intermediate

Re: Process Instance name has no default value ?

Interesting question.

The code in RestResponseFactory.createProcessInstanceResponse certainly indicates the name is being added to the response but for some reason it's not showing up.

Strange.

Greg

ppcchh
Active Member

Re: Process Instance name has no default value ?

Thanks for the reply.

Maybe my original post is a bit confusing when is say 

although a field NAME_ is present in ACT_HI_PROCINST

What I meant is the field is indeed present in the DB schema, but the value is null. Then in my case it is not that weird it does not show up in the response.

What is more questionable it is why the engine do not default name the process instance with the process definition name.

Maybe the name is intented to be set manually via a listener ? 

gdharley
Intermediate

Re: Process Instance name has no default value ?

Hmm, NAME_ seems to be populated for me.