Publish to Alfresco Task not work in Alfresco install in Windows Spanish

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Established Member II

Publish to Alfresco Task not work in Alfresco install in Windows Spanish

Hello!

Environment of work:

Activiti Enterprise 1.5 in Windows (Spanish installation)

Alfresco One 5.1 in Windows (Spanish installation)

When I retrieve folders and files from site has produced an error.

Retrieve sites is fine:

But if choice a site:

In Chrome:

I activated Activiti logs and...

2018-01-10 11:57:25,678 DEBUG [org.apache.chemistry.opencmis.client.bindings.spi.atompub.CmisAtomPubSpi] [http-nio-9080-exec-8] Initializing AtomPub SPI...
2018-01-10 11:57:25,744 DEBUG [org.apache.chemistry.opencmis.client.bindings.spi.http.DefaultHttpInvoker] [http-nio-9080-exec-8] GET http://localhost:8080/alfresco/api/-default-/public/cmis/versions/1.0/atom?repositoryId=-default-
2018-01-10 11:57:26,077 DEBUG [org.apache.chemistry.opencmis.client.bindings.spi.http.DefaultHttpInvoker] [http-nio-9080-exec-8] GET http://localhost:8080/alfresco/api/-default-/public/cmis/versions/1.0/atom/path?path=%2FSites%2Forga...
2018-01-10 11:57:26,100 DEBUG [org.springframework.web.servlet.mvc.method.annotation.ExceptionHandlerExceptionResolver] [http-nio-9080-exec-8] Resolving exception from handler [public com.activiti.model.common.ResultListDataRepresentation com.activiti.rest.runtime.integration.AlfrescoOnPremResource.getContentInSite(java.lang.String,java.lang.String)]: com.activiti.service.exception.BadRequestException: Error while getting site content

I test URL and I think this is the error:

If I change Sites for Sitios then work fine!

Then, possible cause: Activiti not use Sites/Sitios/... for Alfresco language.

Is there any way easy to change this in Activiti?

Note: Even if Alfresco is installed with the English installer, in a Windows in Spanish it always creates the sites as "Sitios".

Regards,

fegor

4 Replies
Highlighted
Established Member II

Re: Publish to Alfresco Task not work in Alfresco install in Windows Spanish

Well, the error is in a class: AlfrescoContentService, in method: getContentInSite(String userId, AlfrescoContext context, String siteId) {...}

This value is hardcoded!

public List<AlfrescoContent> getContentInSite(String userId, AlfrescoContext context, String siteId) {
  ...
      Folder siteObject = (Folder) cmisbe.getObjectByPath("/Sites/" + siteId, this.getSimpleOperationContext());
      ArrayList content = new ArrayList();
      ...
}

I don't understant why this... :-(

The Alfresco installation in Windows (Spanish language) create '/Sitios' not '/Sites'. Is neccesary use internationalization with properties or variables please!

Highlighted
Senior Member II

Re: Publish to Alfresco Task not work in Alfresco install in Windows Spanish

Thanks for raising this issue Fernando, not good! Could you please raise a case with Alfresco on this issue?

Regards,

Ciju

Highlighted
Established Member II

Re: Publish to Alfresco Task not work in Alfresco install in Windows Spanish

Hi, Ciju:

I don't know where raise this case with Alfresco. In support.alfresco.com?

Highlighted
Established Member II

Re: Publish to Alfresco Task not work in Alfresco install in Windows Spanish

A workaround is change the name of Sitios to Sites:

In 'Edit properties'.

Regards,

Fegor