Unable to trigger events with event based gateway after upgrade from Activiti 5.19 to 6.0

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

Unable to trigger events with event based gateway after upgrade from Activiti 5.19 to 6.0

Existing processes that were waiting on signal or timer intermediate catch events with event gateways can't be triggered after the upgrade (stack trace below). V5 compatibility mode is disabled. Is it necessary to have compatibility mode enabled for proper transitioning of existing active events with event gateways after the upgrade ? 

2019-10-16 20:29:10,778 | INFO | LS_IN | | | Activiti 5 compatibility handler implementation not found or error during instantiation : org.activiti.compatibility.DefaultActiviti5CompatibilityHandler. Activiti 5 backwards compatibility disabled.
2019-10-16 20:29:10,876 | INFO | LS_IN | | | ProcessEngine default created
2019-10-16 20:29:10,878 | INFO | LS_IN | | | Starting up the default async job executor [org.activiti.engine.impl.asyncexecutor.DefaultAsyncJobExecutor].

2019-10-16 20:29:10,883 | INFO | LS_IN | | | {} starting to acquire async jobs due
2019-10-16 20:29:10,884 | INFO | LS_IN | | | {} starting to acquire async jobs due
2019-10-16 20:29:10,884 | INFO | LS_IN | | | {} starting to reset expired jobs
2019-10-16 20:29:11,312 | ERROR | LS_IN | | | Error while closing command context
org.activiti.engine.ActivitiException: this activity isn't waiting for a trigger
at org.activiti.engine.impl.bpmn.behavior.FlowNodeActivityBehavior.trigger(FlowNodeActivityBehavior.java:54) ~[activiti-engine-6.0.0.jar:6.0.0]
at org.activiti.engine.impl.agenda.TriggerExecutionOperation.run(TriggerExecutionOperation.java:38) ~[activiti-engine-6.0.0.jar:6.0.0]
at org.activiti.engine.impl.interceptor.CommandInvoker.executeOperation(CommandInvoker.java:73) ~[activiti-engine-6.0.0.jar:6.0.0]
at org.activiti.engine.impl.interceptor.CommandInvoker.executeOperations(CommandInvoker.java:57) ~[activiti-engine-6.0.0.jar:6.0.0]
at org.activiti.engine.impl.interceptor.CommandInvoker.execute(CommandInvoker.java:42) ~[activiti-engine-6.0.0.jar:6.0.0]
at org.activiti.engine.impl.interceptor.TransactionContextInterceptor.execute(TransactionContextInterceptor.java:48) ~[activiti-engine-6.0.0.jar:6.0.0]
at org.activiti.engine.impl.interceptor.CommandContextInterceptor.execute(CommandContextInterceptor.java:63) [activiti-engine-6.0.0.jar:6.0.0]
at org.activiti.spring.SpringTransactionInterceptor$1.doInTransaction(SpringTransactionInterceptor.java:47) [activiti-spring-6.0.0.jar:6.0.0]
at org.springframework.transaction.support.TransactionTemplate.execute(TransactionTemplate.java:133) [spring-tx-4.3.20.RELEASE.jar:4.3.20.RELEASE]
at org.activiti.spring.SpringTransactionInterceptor.execute(SpringTransactionInterceptor.java:45) [activiti-spring-6.0.0.jar:6.0.0]
at org.activiti.engine.impl.interceptor.LogInterceptor.execute(LogInterceptor.java:29) [activiti-engine-6.0.0.jar:6.0.0]
at org.activiti.engine.impl.cfg.CommandExecutorImpl.execute(CommandExecutorImpl.java:44) [activiti-engine-6.0.0.jar:6.0.0]
at org.activiti.engine.impl.cfg.CommandExecutorImpl.execute(CommandExecutorImpl.java:39) [activiti-engine-6.0.0.jar:6.0.0]
at org.activiti.engine.impl.asyncexecutor.ExecuteAsyncRunnable.executeJob(ExecuteAsyncRunnable.java:97) [activiti-engine-6.0.0.jar:6.0.0]
at org.activiti.engine.impl.asyncexecutor.ExecuteAsyncRunnable.run(ExecuteAsyncRunnable.java:75) [activiti-engine-6.0.0.jar:6.0.0]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:1.8.0_92]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:1.8.0_92]
at java.lang.Thread.run(Thread.java:745) [?:1.8.0_92]