Uploaded file on a process task does not display thumbnail

cancel
Showing results for 
Search instead for 
Did you mean: 
Professional

Uploaded file on a process task does not display thumbnail

In Alfresco Process Services 1.9.0.3, when you upload a file to the out-of-the-box task form that is part of the task app, a thumbnail will be rendered and displayed after uploading, as shown below, which is great:

Screen Shot 2019-12-11 at 6.16.11 PM.png

However, when you use the Upload form control on a form in a custom process, a thumbnail is not generated, as shown below, which is not what we expected:

Screen Shot 2019-12-11 at 6.15.44 PM.png

Maybe there is an option or a style or something else that we are supposed to specify in the form design when using this control? If so, what is it and where is it documented?

Or is this a bug?

5 Replies
Community Manager
Community Manager

Re: Uploaded file on a process task does not display thumbnail

Do you have the 

"showDocumentContent":true 
 
set? This is what determines if the content (thumbnail) is visible or not.
Professional

Re: Uploaded file on a process task does not display thumbnail

Where is that set?

Just to be clear, I'm designing the form in the form editor of the activiti-app in APS 1.9.0.3. The file upload control has the following tabs: General, Attach File Options, Visibility, and Style.

Community Manager
Community Manager

Re: Uploaded file on a process task does not display thumbnail

I do not see this behaivor. When I add a document using the form - it is not displayed. Only the name of the file.

Screen Shot 2019-12-16 at 10.52.27 AM.png

Then when I look at the running processes, I see the thumbnail you are referring to.

Screen Shot 2019-12-16 at 10.52.41 AM.png

Finally, if I display the value (contents) of this field showing "show content embedded in form" when I create the form.

Screen Shot 2019-12-16 at 10.54.38 AM.png 

Then I see something like this.

Screen Shot 2019-12-16 at 10.52.53 AM.png

Where did you get the screenshot you are showing in your original message?

Professional

Re: Uploaded file on a process task does not display thumbnail

Yes, when you look at the *process* the thumbnail shows up.

Look at the out-of-the-box Task App. When you add a content item, the thumbnail shows up immediately.

Now look at your test process. When you added that attachment, the thumbnail did not show up on the task form. You had to actually view the running process to see it.

So if you start a process, or if you are assigned a task in a process, and you upload a file, the thumbnail is never displayed for some reason. It isn't displayed immediately upon upload (like it is for the OOTB Task App) and it is not displayed if you save the task and return to it. The control just shows the file name, like it is in your screenshot.

Community Manager
Community Manager

Re: Uploaded file on a process task does not display thumbnail

This is working as designed with the out of the box Form controls.