We've upgraded some of our developers to 1.6.1 and they are getting the following errors on a imported process that uses a script step. 09-Jun-2017 14:06:05.024 SEVERE [http-nio-9999-exec-4] org.apache.catalina.core.StandardWrapperValve.invoke Servlet.se

cancel
Showing results for 
Search instead for 
Did you mean: 
navonodt
Active Member

We've upgraded some of our developers to 1.6.1 and they are getting the following errors on a imported process that uses a script step. 09-Jun-2017 14:06:05.024 SEVERE [http-nio-9999-exec-4] org.apache.catalina.core.StandardWrapperValve.invoke Servlet.se

Jump to solution

09-Jun-2017 14:06:05.024 SEVERE [http-nio-9999-exec-4] org.apache.catalina.core.StandardWrapperValve.invoke Servlet.service() for servlet [appDispatcher] in context with path [/activiti-app] threw exception [Request processing failed; nested exception is org.activiti.engine.ActivitiException: You are not allowed to execute 'javascript' scripts.] with root cause
org.activiti.engine.ActivitiException: You are not allowed to execute 'javascript' scripts.

We put the following properties in the activiti-app.properties file

validator.editor.bpmn.disable.scripttask=false
validator.editor.bpmn.disable.scripttask.groovy=false
Any ideas?
1 Solution

Accepted Solutions
cjose
Senior Member II

Re: We've upgraded some of our developers to 1.6.1 and they are getting the following errors on a imported process that uses a script step. 09-Jun-2017 14:06:05.024 SEVERE [http-nio-9999-exec-4] org.apache.catalina.core.StandardWrapperValve.invoke Servle

Jump to solution

There is another file named whitelisted-scripts.conf in classes/activiti folder. Do you have "javascript" uncommented in there?

Ciju

6 Replies
cjose
Senior Member II

Re: We've upgraded some of our developers to 1.6.1 and they are getting the following errors on a imported process that uses a script step. 09-Jun-2017 14:06:05.024 SEVERE [http-nio-9999-exec-4] org.apache.catalina.core.StandardWrapperValve.invoke Servle

Jump to solution

There is another file named whitelisted-scripts.conf in classes/activiti folder. Do you have "javascript" uncommented in there?

Ciju

navonodt
Active Member

Re: We've upgraded some of our developers to 1.6.1 and they are getting the following errors on a imported process that uses a script step. 09-Jun-2017 14:06:05.024 SEVERE [http-nio-9999-exec-4] org.apache.catalina.core.StandardWrapperValve.invoke Servle

Jump to solution

The strange thing is that it appears to be only on new fresh installs of 1.6.1.  On my machine that i have upgraded from 1.5.3 it works fine.   I will check on the developer's machine who is having the problem.  I don't have the file you mention above at all.  I have these which I haven't touched.

beans-whitelist.conf

javascript-whitelist-classes.conf

shell-commands-whitelist.conf

call-whitelist.conf

service-task-whitelist-classes.conf

version.properties

cjose
Senior Member II

Re: We've upgraded some of our developers to 1.6.1 and they are getting the following errors on a imported process that uses a script step.  09-Jun-2017 14:06:05.024 SEVERE [http-nio-9999-exec-4] org.apache.catalina.core.StandardWrapperValve.invoke Servle

Jump to solution

I am running 1.6.2 where there is a file called whitelisted-scripts.conf. Can you please check if it is 1.6.2 that the developers have on their machine?

navonodt
Active Member

Re: We've upgraded some of our developers to 1.6.1 and they are getting the following errors on a imported process that uses a script step. 09-Jun-2017 14:06:05.024 SEVERE [http-nio-9999-exec-4] org.apache.catalina.core.StandardWrapperValve.invoke Servle

Jump to solution

They are definitely running 1.6.1.

navonodt
Active Member

Re: We've upgraded some of our developers to 1.6.1 and they are getting the following errors on a imported process that uses a script step. 09-Jun-2017 14:06:05.024 SEVERE [http-nio-9999-exec-4] org.apache.catalina.core.StandardWrapperValve.invoke Servle

Jump to solution

I stand corrected.  they did get the 1.6.2 bits. and your suggestion above fixed it

rohit9637
Established Member

Re: We've upgraded some of our developers to 1.6.1 and they are getting the following errors on a imported process that uses a script step. 09-Jun-2017 14:06:05.024 SEVERE [http-nio-9999-exec-4] org.apache.catalina.core.StandardWrapperValve.invoke Servle

Jump to solution

We have deployed APS 1.9.0.1 to k8s cluster and now I need to modify whitelisted-scripts.conf file to execute a process having script task.

How could we extend the whitelisted-scripts.conf file?