Adding Processes to the Content app

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Customer

Adding Processes to the Content app

Hello,

I want to create a Content and Process ADF app, building on the Alfresco Content Application, rather than starting from scratch.

The Alfresco Content Application is a Content app so it's not connected to APS. How can I configure it so it becomes a Content and Process app?

Thanks

3 Replies
Highlighted
Alfresco Employee

Re: Adding Processes to the Content app

You need at least the following:

  • install the Process related dependencies (@alfresco/adf-process-services and others)
  • update the app.config.json to use the "ALL" providers for the authentication
Highlighted
Member II

Re: Adding Processes to the Content app

Hi,

I have a similar problem.

Adding the @alfresco/adf-process-services dependency and updating app.config.json worked for me on an older version of the content app...

  "dependencies": {
    "@alfresco/aca-shared""^1.12.0",
    "@alfresco/adf-content-services""3.7.0",
    "@alfresco/adf-core""3.7.0",
    "@alfresco/adf-extensions""3.7.0",
    "@alfresco/adf-insights""3.7.0",
    "@alfresco/adf-office-services-ext""0.0.9",
    "@alfresco/adf-process-services""^3.9.0",
    "@alfresco/js-api""3.7.0",
    "@angular/animations""7.2.15",
    "@angular/cdk""^7.3.7",
    "@angular/common""7.2.15",
    "@angular/compiler""7.2.15",
    "@angular/core""7.2.15",
    "@angular/flex-layout""^7.0.0-beta.24",
    "@angular/forms""7.2.15",
    "@angular/http""7.2.15",
    "@angular/material""^7.3.7",
    "@angular/material-moment-adapter""^7.3.7",
    "@angular/platform-browser""7.2.15",
    "@angular/platform-browser-dynamic""7.2.15",
    "@angular/router""7.2.15",
    "@mat-datetimepicker/core""^3.1.0",
    "@mat-datetimepicker/moment""^3.1.0",
    "@ngrx/effects""^7.4.0",
    "@ngrx/router-store""^7.4.0",
    "@ngrx/store""^7.4.0",
    "@ngrx/store-devtools""^7.4.0",
    "@ngx-translate/core""^11.0.1",
    "core-js""^2.6.11",
    "cors""^2.8.5",
    "hammerjs""2.0.8",
    "minimatch-browser""^1.0.0",
    "moment""^2.27.0",
    "moment-es6""1.0.0",
    "path""^0.12.7",
    "pdfjs-dist""2.0.489",
    "rxjs""^6.6.0",
    "zone.js""0.8.29"

 

... but when I tried to update to the newest version I was getting a lot of errors

errors.PNG

Does that mean the process services dependency is somehow not compatible with the newest version of the content app? If no, how do I update the app?

Cheers!

Highlighted
Alfresco Employee

Re: Adding Processes to the Content app

Based on your errors, you are getting the unreleased "development" branch with the Angular 10 upgrade that is going on. Use "master" branch if you want accessing the released content.