ADF upgrade from 2.3.0 to 2.6.0 issue

cancel
Showing results for 
Search instead for 
Did you mean: 
Active Member II

ADF upgrade from 2.3.0 to 2.6.0 issue

Hello, Thank you for your time. I already address this issue on gitter chat, but I wanted to give more details on this Issue.

So, I had ADF 2.3.0 with big modifications, Seeing that we were getting behind by far on ADF updates, we decided to update our app library to 2.6.0. For that I followed this guide:

How to update ADF from version 2.4.0 to 2.5.0 

First I updated my app to 2.4.0 but I started to have the same issue that I'm going to describe below. then, I follow the guide to update to ADF 2.6.0 and resolving all the dependency issues and modify the code to adapt to RXJS changes. My application build was ok, without any issue (). build:

Maybe these npm ERR! are causing the issue?, It's wierd because I had them before and the app was working fine on 2.3.0.

These are the dependencies con package.json:

So, if everything looks find, I started my application with docker-compose and on the logs I saw that the apps compiled correctly:

So, A big modification of my app, it's that We use an application "Flowable-idm" to create the ECM ticket and log against alfresco, this was working all good on 2.3.0. below the code:

On login.component.ts we changed it to:

So, if the ticket doesn't exist, it will redirect to flowable-idm to perform the login and then back to the application ['home']. this was working find on 2.3.0.

The issue that I'm having is that: When I open my adf app, It loads the login ok and since the ticket is not on the localstorage it sends me to flowable-idm ok, then I log in and flowable-idm redirect me ok to the ADF loging but that's it. the application doesnt navigate to ['Home'], it stays with a blank page on http://192.168.99.100/#/login follow image below:

I don't any help from these error and on the docker logs it doesn't show anything. just call from proxy. these below are part of my nginx prox

I thought that maybe is a proxy problem?, I'm really out of ideas, if anyone could help me I appreciate. I can give you more details if you need.

PD: I'm so sorry for my english.

5 Replies
Active Member II

Re: ADF upgrade from 2.3.0 to 2.6.0 issue

Update: Checking login component with break points after a few proccess it show this:

At that moment is when navigation is cancelled and nothing happens.

Alfresco Employee

Re: ADF upgrade from 2.3.0 to 2.6.0 issue

We do not support Flowable on this forum.

Alfresco Employee

Re: ADF upgrade from 2.3.0 to 2.6.0 issue

Upgrade to APS 1.9

Active Member II

Re: ADF upgrade from 2.3.0 to 2.6.0 issue

Thanks for your clarification, but, These codes are not from flowable, these are in ADF app, Im just using flowable there to make de request to alfresco to create the ECM Ticket, thats it.

The issue apparently is with the navigation of adf.

Active Member II

Re: ADF upgrade from 2.3.0 to 2.6.0 issue

I'm not using APS in my setup. just Alfresco Community Edition 6.0.