adf-userinfo appears on chrome but not on firefox

cancel
Showing results for 
Search instead for 
Did you mean: 
anakin98000
Member II

adf-userinfo appears on chrome but not on firefox

Hello,

I use Angular 7.2, adf-content-services 3.5.0, adf-core 3.5.0 and js/api 3.5.0

I use the following alfresco composent in a angular component:

<adf-userinfo class="adf-app-layout-user-profile" [menuPositionX]="'before'" [menuPositionY]="'above'">
</adf-userinfo>

I have a scss file with it.

It works nice on chrome :-)  :

adfuser-local.png

 

But it doesn't appear on firefox (and IE):

adfuser-production.png

What is missing ?

I compare config files  with an othe projet where this composent appears in production but I don't find the problem

Thank's in advance

5 Replies
EddieMay
Community Manager
Community Manager

Re: adf-userinfo appears on chrome but not on firefox

Hi @anakin98000 

In Firefox - is there anything in the Developer Console or Network tabs that indicate an issue? If not, can you see the component output in the HTML source code?

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!
anakin98000
Member II

Re: adf-userinfo appears on chrome but not on firefox

Hi,

I see the component :

inspection.png

 

And there is just a warning message (i don't know if there is a link)

If i translate (excuse my english) : "Some cookies use incorrectly SameSite recommended attribute"  adf-core.js:1792

 

Thank you for your help

firefow warning.png

anakin98000
Member II

Re: adf-userinfo appears on chrome but not on firefox

Waouhh ! In the same window, If I open a new tab with another project that uses too this component (that works), and then I refresh the first tab, the coponent is displayed !! 

Can it be css or scss files conflicts ?

anakin98000
Member II

Re: adf-userinfo appears on chrome but not on firefox

In angular.json, i have removed for testing the other css files references, same result...

EddieMay
Community Manager
Community Manager

Re: adf-userinfo appears on chrome but not on firefox

Hi @anakin98000 

Could it be a caching issue with Firefox? Can you try using Icognito mode - this should use a fresh cache - and see if it appears as expected?

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!