Alfresco error after update

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member

Alfresco error after update

Jump to solution

Hello,

I updated alfresco 2.4.010 to 2.5.0 and I did exactly as it suggests in the article.

After I run the application after the update  I receive this error.

ERROR in node_modules/@alfresco/adf-core/utils/file-utils.d.ts(18,13): error TS2304: Cannot find name 'WebKitFileEntry'.

Does anyone know how to fix it?

1 Solution

Accepted Solutions
Highlighted
Alfresco Employee

Re: Alfresco error after update

Jump to solution

You have probably installed the most recent version of typescript instead of the one coming with the project.

See this article for more details on deprecated features in typescript 3: Breaking Changes · Microsoft/TypeScript Wiki · GitHub 

View solution in original post

5 Replies
Highlighted
Alfresco Employee

Re: Alfresco error after update

Jump to solution

You may have an outdated version of Typescript, try running "npm i -D typescript@latest" in your project

Highlighted
Active Member

Re: Alfresco error after update

Jump to solution

I did run it, and I have the same problem.

Highlighted
Alfresco Employee

Re: Alfresco error after update

Jump to solution

You have probably installed the most recent version of typescript instead of the one coming with the project.

See this article for more details on deprecated features in typescript 3: Breaking Changes · Microsoft/TypeScript Wiki · GitHub 

View solution in original post

Highlighted
Member II

Re: Alfresco error after update

Jump to solution

I am also facing same issue. 

Highlighted
Alfresco Employee

Re: Alfresco error after update

Jump to solution

Please see the Denys Vuika‌ Comment above