Upgrade 3.5.0 to 3.9.0 : TypeError: this.customLoader.setDefaultLang is not a function.

cancel
Showing results for 
Search instead for 
Did you mean: 
anakin98000
Member II

Upgrade 3.5.0 to 3.9.0 : TypeError: this.customLoader.setDefaultLang is not a function.

Hi,

i have following message after upgrading from 3.5 to 3.9 : TypeError: this.customLoader.setDefaultLang is not a function. The only thing I add is "TranslateModule.forRoot()" in app.module...

"@alfresco/adf-content-services": "3.9.0",
"@alfresco/adf-core": "3.9.0",
"@alfresco/adf-insights": "3.9.0",
"@alfresco/adf-extensions": "3.9.0",
"@alfresco/js-api": "3.9.0",
"@ngx-translate/core": "^11.0.1",

I add in AppModule: 

TranslateModule.forRoot()

What is missing ?

Thanks in advance

 

Edit:

line error : new TranslationService (adf-core.js:4664)