Integrity Error after Alfresco Upgrade

cancel
Showing results for 
Search instead for 
Did you mean: 
texano
Member II

Integrity Error after Alfresco Upgrade

Hi,

I've upgrade my Alfresco installation with 20GB repository content from 4.2.C to the newest 5.0.D.
Now we are having errors related to "Mandatory property not set" and "node.integrity.IntegrityException" when creating new sites, viewing tasks, etc. This errors are show in Alfresco Share page and in catalina.out logs.
Please check the attached files.


2015-04-25 19:57:54,094  ERROR [extensions.webscripts.AbstractRuntime] [http-apr-8080-exec-8] Exception from executeScript - redirecting to status template error: 03250167 Found 1 integrity violations:
Mandatory property not set:
   Node: workspace://SpacesStore/32fddf43-103a-4f48-b001-b48552dff3ad
   Name: 32fddf43-103a-4f48-b001-b48552dff3ad
   Type: {http://www.alfresco.org/model/content/1.0}person
   Property: {http://www.alfresco.org/model/content/1.0}sizeCurrent
org.alfresco.repo.node.integrity.IntegrityException: 03250167 Found 1 integrity violations:
Mandatory property not set:
   Node: workspace://SpacesStore/32fddf43-103a-4f48-b001-b48552dff3ad
   Name: 32fddf43-103a-4f48-b001-b48552dff3ad
   Type: {http://www.alfresco.org/model/content/1.0}person
   Property: {http://www.alfresco.org/model/content/1.0}sizeCurrent
        at org.alfresco.repo.node.integrity.IntegrityChecker.checkIntegrity(IntegrityChecker.java:664)
        at org.alfresco.repo.node.integrity.IntegrityChecker.beforeCommit(IntegrityChecker.java:766)




Can you guys help me with this?

Thank you.

33 Replies
texano
Member II

Re: Integrity Error after Alfresco Upgrade

Hey guys,

Can someone help me with this?

Thanks.
miguel75
Member II

Re: Integrity Error after Alfresco Upgrade

I've exactly the same problem Smiley Sad
Moderator
Moderator

Re: Integrity Error after Alfresco Upgrade

Try to execute a full reindex, removing also the alfrescoModels included in Solr, it should solve your problem.
This because Apache Solr actually includes an old version of the Alfresco content models and you have to remove them for letting Solr to get the newer versions.

Hope this helps.
ceeliro
Member II

Re: Integrity Error after Alfresco Upgrade

Perfect it worked (at least for me)! Thanks a lot
miguel75
Member II

Re: Integrity Error after Alfresco Upgrade

Hi!

Thanks for the reply, but it doesn't work for me Smiley Sad

I've deleted all indexes and alfrescomodels, but the error persists.

With alfresco stopped:
[alfresco@alfresclon solr4]$ pwd
/opt/alfresco5.0.d/alf_data/solr4
[alfresco@alfresclon solr4]$ ls -la
total 20
drwxrwxr-x 5 alfresco alfresco 4096 Apr 29 11:45 .
drwxrwxr-x 8 alfresco alfresco 4096 Apr 29 11:25 ..
drwxrwxr-x 3 alfresco alfresco 4096 Apr 29 11:46 content
drwxrwxr-x 4 alfresco alfresco 4096 Apr 29 11:45 index
drwxrwxr-x 2 alfresco alfresco 4096 Apr 29 11:46 model
[alfresco@alfresclon solr4]$ rm -rf *

[alfresco@alfresclon alfrescoModels]$ pwd
/opt/alfresco5.0.d/solr4/alfrescoModels
[alfresco@alfresclon alfrescoModels]$ rm -rf *


miguel75
Member II

Re: Integrity Error after Alfresco Upgrade

I've tried upgrading to 5.0a instead of 5.0d and now it's working ok.

texano
Member II

Re: Integrity Error after Alfresco Upgrade

Hey,

The reindex did not work for me Smiley Sad
Still have the same error

Mandatory property not set:
   Node: workspace://SpacesStore/1ad6e30b-7b4d-4886-9d79-80ad6707ecca
   Name: 1ad6e30b-7b4d-4886-9d79-80ad6707ecca
   Type: {http://www.alfresco.org/model/content/1.0}person
   Property: {http://www.alfresco.org/model/content/1.0}sizeCurrent
texano
Member II

Re: Integrity Error after Alfresco Upgrade

Hi OpenPj,

Reindex did not work here Smiley Sad


Even I need to expand some tab and Alfresco Share i'm getting the error.. Can you help us?
Please check attached file.


Thanks.
ceeliro
Member II

Re: Integrity Error after Alfresco Upgrade

Perform same procedure than before and also set index.recovery.mode=FULL in the alfresco-global.properties