Actualización de Alfresco a la última versión falla

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member

Actualización de Alfresco a la última versión falla

Jump to solution

Saludos:

Estoy intentando actualizar mi Alfresco sobre Linux a la última versión. El procedimiento que he seguido siempre hasta la fecha para actualizar las versiones (en frío) ahora no me funciona. El log de alfresco me indica el siguente error:

2016-11-09 18:07:16,757 ERROR [org.alfresco.repo.admin.ConfigurationChecker] [localhost-startStop-1] CONTENT INTEGRITY ERROR: System content not found in content store.

2016-11-09 18:07:16,757 ERROR [org.alfresco.repo.admin.ConfigurationChecker] [localhost-startStop-1] Ensure that the 'dir.root' property '/opt/alfresco-community/alf_data' is pointing to the correct data location.

2016-11-09 18:07:16,762 ERROR [org.springframework.web.context.ContextLoader] [localhost-startStop-1] Context initialization failed

org.alfresco.error.AlfrescoRuntimeException: 10090001 Ensure that the 'dir.root' property '/opt/alfresco-community/alf_data' is pointing to the correct data location.

....

Si vuelvo a reinstalar la BD y contentstore originales de la última instalación ésta vuelve a funcionar correctamente. He leído algo de problemas con el schema al borrar la nueva BD y crear la antigua, pero me encuentro perdido y no sé por dónde tirar. Ya he revisado la documentación de Alfresco Community pero no encuentro nada.

Ayuda plis :-(

1 Solution

Accepted Solutions
Highlighted
Alfresco Employee

Re: Actualización de Alfresco a la última versión falla

Jump to solution

Buenas, no es por discrepar.

Pero ese error indica en realidad es que lo que tiene en base de datos y lo que tiene en el sistema de ficheros no concuerda. Puede ser debido a una mala restauración de la base de datos en el nuevo entorno de Alfresco.

Software Engineer in Alfresco Search Team.

View solution in original post

5 Replies
Highlighted
Customer

Re: Actualización de Alfresco a la última versión falla

Jump to solution

Buenas Adolfo:

El error que te marca es que no encuentra el contenido del repositorio (el contentstore) por debajo de /opt/alfresco-community/alf_data

Es decir, que no está el contentstore (le falta), lo has movido mal, o los permisos que tiene no son los adecuados y no lo puede leer el usuario que ejecuta alfresco.

Te aconsejo que un upgrade por ejemplo de Alfresco 5.1.e  a Alfresco 5.1.g dispongas las rutas paralelas con:

/opt/alfresco51e

/opt/alfresco51g

evitando rutas genéricas.

Saludos.

--C.

Highlighted
Alfresco Employee

Re: Actualización de Alfresco a la última versión falla

Jump to solution

Buenas, no es por discrepar.

Pero ese error indica en realidad es que lo que tiene en base de datos y lo que tiene en el sistema de ficheros no concuerda. Puede ser debido a una mala restauración de la base de datos en el nuevo entorno de Alfresco.

Software Engineer in Alfresco Search Team.

View solution in original post

Highlighted
Active Member

Re: Actualización de Alfresco a la última versión falla

Jump to solution

Saludos:

Resuelto y tenías toda la razón Ángel. El problema era que tanto la instalación antigua como la nueva la había hecho sobre la misma ruta (/opt/alfresco-community) y no me estaba dando cuenta de que cuando ejecutaba el script de postgres ctl.sh para arrancar las BD siempre estaba usando la misma BD (la de la nueva instalación).

LECCIÓN APRENDIDA. A partir de ahora, cada instalación tendrá como ruta un nombre distinto.

Gracias Ángel por mostrarme el camino.

Highlighted
Alfresco Employee

Re: Actualización de Alfresco a la última versión falla

Jump to solution

Gracias a ti por volver para contárnoslo ;-)

Software Engineer in Alfresco Search Team.
Highlighted
Active Member

Re: Actualización de Alfresco a la última versión falla

Jump to solution

Gracias a ti también César. Al igual que Ángel, tú también habías dado con la solución al problema. Si hubiera tomado por costumbre distinguir cada instalación en una ruta diferente no me habría encontrado con este problema.