Bonjour à tous,Suite à mes tests avec AD et la complexité...

cancel
Showing results for 
Search instead for 
Did you mean: 
htube
Member II

Bonjour à tous,Suite à mes tests avec AD et la complexité...

Bonjour à tous,
Suite à mes tests avec AD et la complexité de mise en oeuvre je me suis rabattu vers ntlm et cela marche plutot bien.
J'ai encore des petits soucis :
1) Il me crée un user au premier login avec le login dans prénom et il ne sait pas récuperer la config du serveur AD mais peut être est ce impossible ?
2) Il me crée un user space du login de l'utilisateur, comment lui dire de ne pas le faire.
3) Je souhaite que l'utilisateur se connecte à la racine principale et n'est pas accès à l'espace invité, mon tableau de bord avec les tutoriaux ainsi de suite. Comment puis je modifier cela, autorisations, accès direct à un espace.
Merci pour votre coup de main.
Pierre L.
4 Replies
lme
Member II

Re: Bonjour à tous,Suite à mes tests avec AD et la complexité...

Bonjour,

1) NTLM n'est utilisé que pour l'authentification, il juste présent pour dire qu'un couple login/mdp est OK ou non. Si l'utilisateur passe l'authentification et qu'il n'existe pas dans la base des utilisateurs interne d'alfresco, alors alfresco crée un utilisateur par défaut sans chercher les informations supplémentaires. Pour récupérer correctement les informations des utilisateurs, il faut utiliser la synchro via LDAP (différent de l'authentification via LDAP), en allant chercher les informations dans Active Directory.

2) Je n'ai jamais vu ce comportement. Mes utilisateurs importés depuis un annuaire LDAP arrivent directement sur l'espace racine (company home) ou leur tableau de bord. Vous utilisez quelle version et quel package d'alfresco ?

3) voir 2 Smiley Happy

Laurent
htube
Member II

Re: Bonjour à tous,Suite à mes tests avec AD et la complexité...

J'utilise la dernière version community 1.4.

2) Ce comportement se produit avec l'authentification ntlm. Le repertoire du nom du user se crée automatiquement au premier login.

3) J'ai bien desactivé l'espace invité (autorisations) mais j'aurais voulu qu'en standard, sans aller dans les préférences de l'utilisateur il pointe directement sur la racine acceuil. De la même manière j'aurais voulu desactiver mon alfresco.
Merci.
Pierre.

PS : C'est vrai que je n'ai pas réussi à mettre en place l'authentification AD et la synchro.
Si quelqu'un a un sample qui fonctionne avec la 1.4 je suis preneur et je modifierai le serveur et user de login.
lme
Member II

Re: Bonjour à tous,Suite à mes tests avec AD et la complexité...

Ok, j'en suis encore avec la version 1.3 d'alfresco.

Le fichier de configuration pour LDAP a été modifié entre les 2 versions.

Alfresco 1.3, on définit un HOME de manière globale pour tous les utilisateurs :
         <!–
        The path to the location of a space to use as the default home folder.
        This folder should be readable by all users, or a group to which all imported users belong.
        –>
        <property name="defaultHomeFolder">
            <value>/app:company_home</value>
        </property>
Alfresco 1.4, le HOME est récupéré depuis un attribut du LDAP :
                <!– Always use the default –>
                <entry key="cm:homeFolderProvider">
                    <null/>
                </entry>
            </map>
        </property>
        <!– Set a default home folder provider –>
        <!– Defaults only apply for values above –>
        <property name="attributeDefaults">
            <map>
                <entry key="cm:homeFolderProvider">
                    <value>personalHomeFolderProvider</value>
                </entry>
Il faut peut-être que vous regardiez du côté de ce paramètre pour régler votre problème.


Laurent
htube
Member II

Re: Bonjour à tous,Suite à mes tests avec AD et la complexité...

Oui, merci.
Le problème comme je l'ai souligné au dessus c'est que j'avais essayé de mettre en place la config ldap pour AD et que j'ai abandonné parce que je ne m'en sortais pas.
Je vais m'y remettre dès que possible, surtout si quelqu'un l'a déjà mis en place sur la 1.4 et veuille bien m'aider.
En effet je ne suis pas un spécialiste.

Je crois me souvenir (voir un de mes vieux posts) que défauthomefolder pose des problèmes dans la 1.4.
Je n'ai pas vu d'équivalent dans la config ntlm qui est beaucoup plus simple.
Pierre.