bug fréquents version 2.1

cancel
Showing results for 
Search instead for 
Did you mean: 
anarcotik
Member II

bug fréquents version 2.1

Bonjour à tous,

je suis en train de travailler sur la réalisation d'un outil de knowledge management / intranet pour mon entreprise.

J'ai fait le choix d'Alfresco car il m'a semblé que c'était une des meilleurs solution du marché cependant je commence un peu a m'inquiéter quand à la mise en production d'ici quelque mois. En effet, cela fait un peu plus d'une semaine que j'utilise Alfresco et il m'arrive très (trop) souvent de me faire insulter par des exception java qui parfois rendent l'utilisation d'Alfresco difficile. Par exemple je ne peux plus rentrer dans un de mes projets web sans avoir l'exception suivante :

javax.faces.FacesException: Cannot get value for expression '#{AVMBrowseBean.webappsSize > 1}'

de même si je veux supprimer ce même projet web j'obtient :
Veuillez corriger les erreurs ci-dessous puis cliquer sur OK.
    * Impossible de supprimer lEspace suite à une erreur système :


Bon ce n'est qu'un exemple parmi quelques cas problématiques.

ma question est la suivante : je travaille sur la version 2.1.0 dite stable, "toutes" ces erreurs sont elles le fruit d'une mauvaise utilisation de ma part? cette version est elle connue pour avoir certains bugs? aurais je oublié d'appliquer un (ou plusieurs) patch résolvant ces petits problèmes?

et au final dois je passer a la version 2.9 pour être tranquil bien qu'elle soit considérée comme une version de développement?

merci de vos réponses.
2 Replies
rguinot
Active Member

Re: bug fréquents version 2.1

Il nous est difficile de répondre en l'état .
Pouvez vous décrire l'environnement de déploiement ? et poster  les traces complètes des erreurs générées (avec la balise CODE)….
michaelh
Active Member

Re: bug fréquents version 2.1

Bonjour,

En complément des remarques de Romain, l'idéal dans ce cas (et si le problème est reproductible) est de fournir une liste des étapes qui mènent au problème (ici on peut juste déduire que ça parle de WCM, mais sans plus).

J'avoue que ces erreurs ne m'évoquent rien de particulier, mais vous êtes aussi peut être tombé sur un bug, personne n'est parfait. Après la 2.9 est une version "mouvante" et en attendant une version stabilisée il est peut être bon de patienter si vous n'êtes pas encore à l'aise avec le produit.