emailListener pour alfresco 4.0.e

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

emailListener pour alfresco 4.0.e

Bonjour,

J'ai essayé d'intégrer emailListener 3.0 avec Alfresco 4.0.e mais j'ai eu cette erreur dans le log
Module 'emailListener' version 3.0 is incompatible with the current repository version 4.0.0.
Est ce qu'il y a une nouvelle version de emailListener compatible avec alfresco 4.0.
Merci d'avance.
3 Replies
Highlighted
Active Member II

Re: emailListener pour alfresco 4.0.e

Bonjour,

Le travail sur emailListener est stoppé depuis quelques temps déjà et les versions d'Alfresco se sont succéder sans qu'emailListener soit mis à jour.
Pour bien faire, le modèle de données de ce module devrait être revu et mis en adéquation avec ce qui existe aujourd'hui nativement dans Alfresco (emailListener a été créé à l'époque ou ni le protocole SMTP, ni le protocole IMAP n'étaient disponibles dans Alfresco).

Si vous souhaitez tout de même faire le test d'EmailListener sur une version 4, vous pouvez commencer par modifier le fichier module.properties. Celui-ci référence la version maximale du repository Alfresco.

Cordialement,
Charles Le Seac'h
Highlighted
Member II

Re: emailListener pour alfresco 4.0.e

Bonjour ,
Merci cleseach pour la réponse.
Les fonctionnalités de emailListener peuvent être assurées par la configuration IMAP et c'est bien décrit dans lien ci-dessous :
https://forums.alfresco.com/fr/viewtopic.php?f=8&t=5275

Cordialement,
Highlighted
Member II

Re: emailListener pour alfresco 4.0.e

Bonjour ,
Merci cleseach pour la réponse.
Les fonctionnalités de emailListener peuvent être assurées par la configuration IMAP et c'est bien décrit dans lien ci-dessous :
https://forums.alfresco.com/fr/viewtopic.php?f=8&t=5275

Cordialement,