Failed to deploy workflow definition

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

Failed to deploy workflow definition

Bonjour tout le monde

J'essaie de déployer mon premier workflow qui est composé de 3 étapes :
- l'initiateur entre un libellé et une description et choisis une personne à qui assigner la tâche
- le document est déplacé dans un autre espace
- la personne à qui la tâche a été assignée valide.

J'ai utilisé jbpm designer pour mon workflow. Je n'arrive pas à le faire marcher, j'ai une exception :
org.alfresco.service.cmr.workflow.WorkflowException: Failed to deploy workflow definition
et je n'ai rien d'autre comme traces donc je ne sais pas par ou prendre le taureau

Voici mon code


<?xml version="1.0" encoding="UTF-8"?>

<process-definition  xmlns="urn:jbpm.org:jpdl-3.2"  name="tacheAdmin">

   <swimlane name="initiator"></swimlane>

   <swimlane name="assignee">
       <assignment class="org.alfresco.repo.workflow.jbpm.AlfrescoAssignment">
          <actor>#{bpm_assignee}</actor>
       </assignment>
   </swimlane>

   <start-state name="debut tache" swimlane="initiator">
      <transition to="request entry"></transition>
   </start-state>

   <task-node name="request entry">
      <task name="enter infos" swimlane="assignee">
         <controller>
            <variable access="read,write,required" name="libelle"></variable>
            <variable access="read,write" name="description"></variable>
         </controller>
      </task>
      <transition to="deplacement"></transition>
   </task-node>

   <node name="deplacement">
      <action name="actionMove" class="com.xgs.demat.actions.MoveToActionHandler"></action>
      <transition to="approbation"></transition>
   </node>

   <task-node name="approbation">
      <task name="approve" swimlane="assignee"></task>
      <transition to="end-state1"></transition>
   </task-node>

   <end-state name="end-state1"></end-state>
   <task>
</task>
</process-definition>

Je suis désespérée, alors si quelqu'un a une idée du problème, svp répondez moi
Merci
1 Reply
Highlighted
Active Member

Re: Failed to deploy workflow definition

Bjr,

Une idée en passant… mais aucune garantie…

Vérifier la prise en compte de votre action par Alfresco

<action name="actionMove" class="com.xgs.demat.actions.MoveToActionHandler"></action>

Il se peut qu'il n'apprecie pas trop… Essayer d'utiliser plutôt les class de base d'Alfresco.

Pour de plus amples informations sur le workflow dans Alfresco :
Cf : http://wiki.alfresco.com/wiki/WorkflowAdministration
http://wiki.alfresco.com/wiki/Workflow
http://ecmarchitect.com/archives/2007/11/19/785