Google Docs

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member

Re: Google Docs

Ok

par défaut l'interface d'intégration de googledocs n'est pas accessible dans share au niveau des dossier. Visiblement il y aurait un problème quelquepart que je n'arrive pas à identifier, celle-ci devrait être disponible avec le code suivant, déjà présent dans alfresco-global.properties :
# Enables google editable functionality
googledocs.googleeditable.enabled=true

… Par conséquent, je te propose de rajouter ce code dans le fichier share-config-custom.xml qui se trouve dans :
$ALFERESCO/tomcat/shared/classes/alfresco/web-extension/ 
en modifiant le enabled à true au lien de false par défaut.
      <!–
         Google Docs™ integration
      –>
      <google-docs>
         <!–
            Enable/disable the Google Docs UI integration (Extra types on Create Content menu, Google Docs actions).
         –>
         <enabled>true</enabled>
         <!–
            The mimetypes of documents Google Docs allows you to create via the Share interface.
            The I18N label is created from the "type" attribute, e.g. google-docs.doc=Google Docs&trade; Document
         –>
         <creatable-types>
            <creatable type="doc">application/msword</creatable>
            <creatable type="xls">application/vnd.ms-excel</creatable>
            <creatable type="ppt">application/vnd.ms-powerpoint</creatable>
         </creatable-types>
      </google-docs>

Ne pas oublier de stopper et de redémarrer Alfresco.
Highlighted
Member II

Re: Google Docs

Dans quelle balise il faut le mettre? je test toutes les possibilités actuellement.
Sinon je viens de tester juste la partie à mettre dans alfresco-global sur une autre version sur windows et j'ai exactement le même problème.

Si tu es en ligne et que tu sais dans quelle balise, je dois mettre le code, ça serait cool
sinon, je reviens après avoir fait toutes les possibilités.
Highlighted
Member II

Re: Google Docs

Bon ba ça n'a pas fonctionné. Voici les endroits où j'ai positionné le code :

<alfresco-config>

   <!– Repository Library config section –>
   <config evaluator="string-compare" condition="RepositoryLibrary" replace="true">
      <!–
         Whether the link to the Repository Library appears in the header component or not.
      –>
      <visible>true</visible>
   </config>

   <config evaluator="string-compare" condition="Remote">
      <remote>
         <endpoint>
            <id>alfresco-noauth</id>
            <name>Alfresco - unauthenticated access</name>
            <description>Access to Alfresco Repository WebScripts that do not require authentication</description>
            <connector-id>alfresco</connector-id>
            <endpoint-url>http://localhost:8081/alfresco/s</endpoint-url>
            <identity>none</identity>
         </endpoint>

         <endpoint>
            <id>alfresco</id>
            <name>Alfresco - user access</name>
            <description>Access to Alfresco Repository WebScripts that require user authentication</description>
            <connector-id>alfresco</connector-id>
            <endpoint-url>http://localhost:8081/alfresco/s</endpoint-url>
            <identity>user</identity>
         </endpoint>

         <endpoint>
            <id>alfresco-feed</id>
            <name>Alfresco Feed</name>
            <description>Alfresco Feed - supports basic HTTP authentication via the EndPointProxyServlet</description>
            <connector-id>http</connector-id>
            <endpoint-url>http://localhost:8081/alfresco/s</endpoint-url>
            <basic-auth>true</basic-auth>
            <identity>user</identity>
         </endpoint>
           ICI
      </remote>
        ICI
   </config>
    ICI
</alfresco-config>
ICI

Malheureusement rien n'a fonctionné…

Si tu as d'autres idées, ça serait cool Smiley Happy
Highlighted
Member II

Re: Google Docs

j'ai finalement vu qu'il y avait un fichier sample.

J'ai ajouté cela :

<!– Document Library config section –>
   <config evaluator="string-compare" condition="DocumentLibrary" replace="true">
<!–
         Google Docsâ     –>
      <google-docs>
         <!–
            Enable/disable the Google Docs UI integration (Extra types on Create Content menu, Google Docs actions).
         –>
         <enabled>true</enabled>

         <!–
            The mimetypes of documents Google Docs allows you to create via the Share interface.
            The I18N label is created from the "type" attribute, e.g. google-docs.doc=Google Docs&trade; Document
         –>
         <creatable-types>
            <creatable type="doc">application/msword</creatable>
            <creatable type="xls">application/vnd.ms-excel</creatable>
            <creatable type="ppt">application/vnd.ms-powerpoint</creatable>
         </creatable-types>
      </google-docs>
</config>


entre les balises <alfresco-config> et </alfresco-config>

J'ai maintenant la possibilité de créer du contenue google docs. Je test un peu…

merci beaucoup!!! je vais surement revenir bientôt!
Highlighted
Member II

Re: Google Docs

On avance, on avance !! Merci encore pour ton aide!!

J'ai maintenant la possibilité d'archiver mon document sur google docs ( Check-out ). le document apparaît bien sur google docs.

le check-in ne fonctionne pas. j'ai le message :
impossible d'archiver la copie de travail TEST1 depuis google docs

… Bizarre…
Highlighted
Member II

Re: Google Docs

Hein hein !! il me semblait bien qu'il manquait une url!! he he!! ça marche!!

Donc pour récapituler :
Pour activer google docs sur Alfresco, il faut :

Aller dans  ./tomcat/shared/classes/alfresco-global.properties
et ajouter :
# Enables google editable functionality
googledocs.googleeditable.enabled=true

# Google docs application name
googledocs.application.name=Alfresco ECM system

# Google docs URL (ne pas modifier cette adresse)
googledocs.url=http://docs.google.com/feeds/default/private/full
googledocs.downloadurl=https://docs.google.com/feeds/download

# System google docs authentication credentials
googledocs.username=user@gmail.com
googledocs.password=mdp

# Google docs spreadsheet service name
googledocs.spreadsheet.service.name=wise

puis aller dans le fichier
./tomcat/shared/classes/alfresco/web-extension/share-config-custom.xml

et ajouter entre les balises <alfresco-config> et </alfresco-config> :

<!– Document Library config section –>
<config evaluator="string-compare" condition="DocumentLibrary" replace="true">
<!–
Google Docsâ –>
<google-docs>
<!–
Enable/disable the Google Docs UI integration (Extra types on Create Content menu, Google Docs actions).
–>
<enabled>true</enabled>

<!–
The mimetypes of documents Google Docs allows you to create via the Share interface.
The I18N label is created from the "type" attribute, e.g. google-docs.doc=Google Docs&trade; Document
–>
<creatable-types>
<creatable type="doc">application/msword</creatable>
<creatable type="xls">application/vnd.ms-excel</creatable>
<creatable type="ppt">application/vnd.ms-powerpoint</creatable>
</creatable-types>
</google-docs>
</config>
Redémarrer Alfresco et hop ça fonctionne!!

Merci à toi et bon courage aux autres Smiley Wink
Highlighted
Active Member

Re: Google Docs

êtes-vous sur de votre login et password sur google docs ?
Highlighted
Active Member

Re: Google Docs

Quelle URL ?

Content que cela marche.
Highlighted
Member II

Re: Google Docs

une minute trop tard Smiley Wink

C'était juste l'url de download qui manquait. Merci encore mon seigneur!!

googledocs.downloadurl=https://docs.google.com/feeds/download

Si tu as une idée pour mon autre problème, n'hésite pas Smiley Happy
++
Olivier
Highlighted
Active Member

Re: Google Docs

Etonnant, je n'ai pas cette url dans mon fichier de configuration et pourtant cela marche …

Bizarre