J'ai un problème lors de la copie de fichier dans...

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

J'ai un problème lors de la copie de fichier dans...

Bonjour,

J'ai un problème lors de la copie de fichier dans le repository via CIFS en utilisant l'explorateur Windows. Les fichiers une fois copiés ont une taille de 0ko (vue depuis l'explorateur et vue depuis le client Web), et il est impossible de les réouvrir…

J'ai testé une copie dans le repository depuis une machine Linux, en utilisant smbclient, et là, par contre, cela fonctionne bien…

J'ai un problème de configuration ou alors c'est un bug???

Ma configuration:
- Alfresco Enterprise 2.1.0 sur serveur Linux Fedora Core 6 (kernel 2.6.20-1.2944), Postgresql 8.1.8
- Windows XP Pro SP2
13 Replies
Highlighted
Member II

Re: J'ai un problème lors de la copie de fichier dans...

Pour compléter la chose, je viens de tester sur la même plateforme :
Un document PPT et un PDF collés par CIFS.
Tous les 2 sont affichés à 0 ko.
Sauf que le PPT je peux l'ouvrir par double-clic dans Powerpoint alors que le PDF me génère une erreur. ("fichier endommagé ou pas pris en charge…") :/

Erwan Esnault
Knowings - Partenaire Alfresco
Highlighted
Active Member

Re: J'ai un problème lors de la copie de fichier dans...

De mon coté je n'ai encore jamais rencontré ce problème j'avoue. Et rien entendu non plus.
Si pas de logs, il pourrait être interessant d'en augmenter le niveau pour voir si il y a des traces en rapport.
Highlighted
Member II

Re: J'ai un problème lors de la copie de fichier dans...

Hello,
nous avons rencontré ce problème avec un utilisateur. Mais cela s'est fini par la réinstallation du serveur après quelques tests.
Highlighted
Active Member

Re: J'ai un problème lors de la copie de fichier dans...

Ca n'explique pas forcément le pourquoi (même si je pense à un problème de communication avec OpenOffice), mais seul le résultat compte parfois Smiley Happy

Merci du retour !
Highlighted
Member II

Re: J'ai un problème lors de la copie de fichier dans...

Bonjour

J'ai analysé ce qui se passe au niveau du dossier content-store et de la base de données.
Quand un fichier est déposé dans le repository via CIFS, on trouve dans le content-store 2 fichiers .bin. Un avec une taille à 0 octet et l'autre à la bonne taille, correspondant au fichier déposé. Malheureusement, dans la base de données, c'est le fichier de 0 octet qui est référencé comme content.

Je n'ai pas encore analysé le code du serveur CIFS, mais je pense qu'un fichier temporaire est créé, il y a un problème lors de la recopie de ce fichier vers la référence définitive. Mais je n'ai aucune trace de ce problème dans les logs, j'ai pourtant monté le niveau jusqu'à INFO (j'ai pas tenté encore le mode DEBUG)

Du côté OpenOffice, on a des régles de transformation de contenu en PDF qui fonctionne très bien sur ce serveur, donc je ne pense pas que cela soit un problème de communication avec OpenOffice.
Highlighted
Active Member

Re: J'ai un problème lors de la copie de fichier dans...

En regardant le release note de la 2.1.1 Entreprise (qui sort du four), je ne vois rien à ce propos. Idem avec JIRA (mais parfois la recherche est complexe selon la façon dont le problème a été remonté).

http://wiki.alfresco.com/wiki/Release_2.1.1

A mon avis ce serait intéressant de le remonter, quitte à avoir ensuite un status "duplicate".
Highlighted
Member II

Re: J'ai un problème lors de la copie de fichier dans...

En effet, j'ai rien trouvé de tel dans JIRA, c'est pourquoi je viens de le tracer… c'est pas la première fois qu'on rencontre ce problème, mais c'était sur des plateformes de développement.

http://issues.alfresco.com/browse/AR-1861
Highlighted
Member II

Re: J'ai un problème lors de la copie de fichier dans...

Bonjour,

Rectification du titre de mon post… c'est pas CIFS et Windows Explorer qui sont pas copain, mais plutôt CIFS et SuperCopier :/
En effet, j'utilise cet outil qui remplace la copie standard Windows. En le désactivant, je ne rencontre plus le problème de fichier avec une taille à 0 octet.

Donc au temps pour moi, bug clos… (enfin ça serait bien que SuperCopier fonctionne avec Alfresco, car c'est bien utile ce genre de petite bête… Smiley Happy )
Highlighted
Active Member

Re: J'ai un problème lors de la copie de fichier dans...

Toujours bon à savoir … merci du retour !