Je suis débutant et je découvre la dernière version...

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

Je suis débutant et je découvre la dernière version...

Bonjour,
Je suis débutant et je découvre la dernière version qui m'enthousiasme !
Par contre pratiquant mal l'anglais, java et autres j'ai beaucoup de mal à trouver des informations sur la configuration à mettre en place pour mettre en place l'authentification Active Directory.
Est ce quelqu'un peut me décrire les étapes, fichiers à configurer ?
D'ailleurs ce serait super d'avoir une démo dans le wiki.
Merci à tous.
Pierre.
12 Replies
Highlighted
Active Member

Re: Je suis débutant et je découvre la dernière version...

Bonjour,

En effet la documentation existe en anglais seulement pour le moment sur http://wiki.alfresco.com/wiki/Enterprise_Security_and_Authentication_Configuration

Je rêve de pouvoir faire une documentation (et plein d'autres), mais les journées ne font que 24 heures …

Je sais que certains lecteurs du forum ont déjà mis en place cette authentification … si un volontaire peut mettre quelques notes à disposition (je veux bien m'occuper de la mise en page si il faut se partager les tâches).

M
Highlighted
Member II

Re: Je suis débutant et je découvre la dernière version...

Bonjour,
Il existe plusieurs méthodes pour utiliser la base active directory pour l'authentification.
La plus simple est l'authentification avec le protocole NTLM (que je viens de tester).
Procédure en anglais ici :
http://wiki.alfresco.com/wiki/Configuring_NTLM

pour résumé cela  :

Editer ntlm-authentification-context.xml.template en ntlm-authentification-context.xml. Ce fichier se trouve pour moi dans /opt/alfresco/tomcat/shared/classes/alfresco/extension/ (ouf !!!).

Le fichier original contient :
<property name="useLocalServer">
           <value>true</value>
</property>
Qu'il faut supprimer si le serveur hote ne fait pas l'authentification ntlm (Controleur de domaine, PDC, BDC ou samba).
A la place l'on peut mettre la propriété "servers" pour spécifié ou se trouve le/les serveur(s) pour l'authentification.
<property name="servers">
           <value>adresseip,nomd'hote</value>
</property>
Redémarrer alfresco

Il faut créer le compte admin d'alfresco dans la base AD (même login)
Un utilisateurs inscrit dans la base AD pourra donc se connecter sur alfresco, mais il n'existera pas avant de se connecter une fois.

Donc cette méthode est a réservé pour ceux qui ont peu d'utilisateurs a géré.

Limitation :
Impossiple de créer des comptes utilisateurs via alfresco
Impossible de modifier/de syncroniser le  mot de passe à partir d'alfresco.
Highlighted
Member II

Re: Je suis débutant et je découvre la dernière version...

Merci, mais j'utilise la version 1.2.1 community windows et je ne trouve pas le ntlm*.* dans aucun repertoire.
D'autre part je ne voie pas comment configurer les cn utilisateurs et groupes.

Si quelqu'un peut me faire passer son bout de code sous windows.
Merci beaucoup.
Highlighted
Member II

Re: Je suis débutant et je découvre la dernière version...

C'est exact je m'en suis rendu compte hier.

La version Windows n'inclu pas le fichier ntlm. tu pourras le trouver dans les fichiers sources sur sourceforge  :
http://prdownloads.sourceforge.net/alfresco/alfresco-src-1.2.1.zip?download
Décompresse et fait une recherche dedans.

Ou si tu attends ce soir je le posterai

Comme je le disais plus haut cela permet juste l'authentification ça ne permet pas la syncronisation.

Un compte AD existant pourra se connecter sur Alfresco en tant qu'invité.
La première connexion crée l'utilisateur dans la base alfresco.
En tant qu'admin tu pourras affecter l'utilisateur a un groupe Alfresco.

Comme je le précisais c'est pas le top quand le nombre d'utilisateur est important, il faut également vérifier la fiabilité du processus en production.

Sinon je suis également intéressé par l'authentification via ldap ou kerberos.
Highlighted
Active Member

Re: Je suis débutant et je découvre la dernière version...

Comme c'est un petit fichier, je colle carrément le contenu ici :

ntlm-authentication-context.xml.sample
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE beans PUBLIC '-//SPRING//DTD BEAN//EN' 'http://www.springframework.org/dtd/spring-beans.dtd'>

<beans>

    <bean id="authenticationDao" class="org.alfresco.repo.security.authentication.ntlm.NullMutableAuthenticationDao" />

    <!– The authentication component.                                      –>

    <!– Use the passthru authentication component to authenticate using    –>
    <!– user accounts on one or more Windows servers.                      –>
   
    <!– Properties that specify the server(s) to use for passthru          –>
    <!– authentication :-                                                  –>
    <!–   useLocalServer   use the local server for authentication         –>
    <!–   domain           use domain controllers from the specified domain–>
    <!–   servers          comma delimted list of server addresses or      –>
    <!–                    names                                           –>
      
    <bean id="authenticationComponentImpl" class="org.alfresco.repo.security.authentication.ntlm.NTLMAuthenticationComponentImpl">
        <property name="useLocalServer">
            <value>true</value>
        </property>
        <property name="personService">
            <ref bean="personService" />
        </property>
        <property name="nodeService">
            <ref bean="nodeService" />
        </property>
        <property name="guestAccess">
            <value>false</value>
        </property>
    </bean>
   
</beans>
Highlighted
Active Member

Re: Je suis débutant et je découvre la dernière version...

Sinon je suis également intéressé par l'authentification via ldap ou kerberos.
Si tout va bien, c'est l'histoire de quelques jours avant de voir arriver de la doc sur LDAP …

(Jérôme si tu me lis Smiley Wink )

M
Highlighted
Member II

Re: Je suis débutant et je découvre la dernière version...

Je viens de mettre en place l'authentification ntlm.
Impeccable !!!!
Merci à tous.

Cela me dépanne déjà. Il est vrai que j'aimerais bien aller plus loin au niveau des groupes, …(ldap)
Highlighted
Member II

Re: Je suis débutant et je découvre la dernière version...

Après install de la 1.3.0 le fichier ntlm-authentication-context.xml ne convient plus.
Le service ne démarre plus, il faut que je le supprime pour qu'alfresco démarre correctement.
Highlighted
Member II

Re: Je suis débutant et je découvre la dernière version...

Après install de la 1.3.0 le fichier ntlm-authentication-context.xml ne convient plus.
Le service ne démarre plus, il faut que je le supprime pour qu'alfresco démarre correctement.
Personne n'a une petite idée ?