Módulo Sistema de Copias de Seguridad Flexible

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
vlopez
Member II

Módulo Sistema de Copias de Seguridad Flexible

Saludos.

¿Alguien ha instalado el Módulo "Sistema de Copias de Seguridad Flexible" desarrollado por INTECNA y que está disponible en el Repositorio de Software Libre de la Junta de Andalucía?.
Llevo al menos una semana intentando instalar el dichoso módulo. He probado con diferentes versiones de Alfresco (2.9B, 2.0 y 2.1). Finalmente parece ser que este módulo está desarrollado para la versión 2.1 según observo en un fichero del propio módulo.
También he probado con JDK 1.6 y después con una versión anterior (1.5), porque en un post leí que el error que me daba podría ser causado por la versión de JAVA.
Incluso he desempaquetado el fichero, he cambiado el module.properties siguiendo las instrucciones de la documentación, pero me sigue dando el mismo error, que parece bastante claro, viene a decir que no encuentra el fichero "module.properties".
¿Alguien conoce este módulo?, ¿lo ha conseguido instalar?….¿alguién podría decirme cómo evitar el error?.

Gracias de antemano.
16 Replies
unknown-user
Active Member

Re: Módulo Sistema de Copias de Seguridad Flexible

Hola,

Lo que has descargado del repositorio de software libre de la Junta de Andalucía es el código fuente del módulo, por lo tanto deberás compilarlo y generar el módulo AMP, para ello deberás utilizar Maven2.

Saludos.
fegor
Established Member II

Re: Módulo Sistema de Copias de Seguridad Flexible

Hola,

El módulo que hay publicado es efectivamete el paquete completo con fuentes y testeos, por lo que previamente hay que compilarlo. Yo lo he compilado instalándome antes el plugin de maven2 en mi eclipse (galileo) y he creado el .amp sin problemas. Lo único que si he hecho ha sido quitar los ficheros de testeos.

¿Puedes explicar mejor los pasos que has ido dando para compilar, instalar y configurar el módulo?

PD. Lo he instalado en un Alfresco ECM 2.1.1

Un saludo,
Fernando González
pjcaracuel_2349
Active Member

Re: Módulo Sistema de Copias de Seguridad Flexible

Hola Fernando,

Habeis pensado subir el amp a la zona de descarga?

Saludos
venzia
Senior Member

Re: Módulo Sistema de Copias de Seguridad Flexible

Y yo sin enterarme que ya estaba disponible :x ! .. aaaaaa por el! Smiley Tongue
fegor
Established Member II

Re: Módulo Sistema de Copias de Seguridad Flexible

Hola,

Por ahora los desarrollos solicitados por la Junta de Andalucía están siendo subidos a su repositorio.

Un saludo,



Hola Fernando,

Habeis pensado subir el amp a la zona de descarga?

Saludos
vlopez
Member II

Re: Módulo Sistema de Copias de Seguridad Flexible

Muchas gracias a todos.
Ya me queda claro el asunto. Ahora me buscaré la vida para compilarlo…jejeje..
Por cierto, muchas gracias a todos los de Intecna por la rápida respuesta, y por supuesto por este desarrollo…ahhh y un saludo a Javier Martínez de Innovasoft.
venzia
Senior Member

Re: Módulo Sistema de Copias de Seguridad Flexible

que tal Tini!, hacia tiempo que no te "veía" por el foro.
Por cierto, me uno a las felicitaciones para intecna por el desarrollo de este componente.
Saludos!
vlopez
Member II

Re: Módulo Sistema de Copias de Seguridad Flexible

Hola a todos de nuevo.

Bien llevo toda la mañana intentando compilar el código del módulo de copias de seguridad flexibles.
Como Eclipse es desconocida para mi, he optado por instalar Maven2 (un proceso sencillo y fácil de encontrar en la web), y después compilar el paquete con el código fuente, mediante el comando "mvn compile", desde la carpeta en la que he incluido el código fuente.
Pues bien, me lanza errores de que no puede acceder a los diferente repositorios que necesita para compilar el módulo, empezando por el maven-amp-plugin-2.0.1.jar
Comprobé las direcciones de los repositorios que me lanza el mensaje de error, y resulta que la de la Junta de Andalucía no existe, y la otra dirección una vez revisada encuentro que no dispone del fichero que la compilación necesita, así que me dije, bueno estará equivocado. Busqué una solución para el plugin y encontré el repositorio del mismo, me lo bajé e instalé el repositorio en mi máquina mediante un comando que aparece en el mismo mensaje de error. (evidentemente todo esto no sin muchos quebraderos de cabeza).
Resultó que cuando ejecuto de nuevo el "mvn compile", me lanza errores de otros archivos necesarios que coinciden con las tres pirmeras dependencias del archivo "pom.xml", en concreto son: alfresco-core ; alfresco-web-client y alfresco-repository

Mi pregunta es….¿Existe ese repositorio de la Junta?, y si no ¿cómo se hace para compilar correctamente?…porque no encuentro esos "artifacts" por ninguna parte.
venzia
Senior Member

Re: Módulo Sistema de Copias de Seguridad Flexible

Hola de nuevo Tini, para montar un entorno de desarrollo (sdk) que permita crear el amp te será útil seguir estos artículos http://wiki.alfresco.com/wiki/Alfresco_SDK y http://wiki.alfresco.com/wiki/Packaging_And_Deploying_Extensions.
Espero que te sirva,
Saludos.