Pas d'accès au document librairy

cancel
Showing results for 
Search instead for 
Did you mean: 
Member II

Pas d'accès au document librairy

Bonjour à tous,
Je viens de déployer la dernière version stable pour faire des tests.
Bizarrement je n'arrive pas à utiliser le "Document Library". Les boutons ne sont pas actifs.
Autre chose bizarre j'ai essayé de passer par Alfresco explorer et j'ai créé un espace à l'intérieur du  "Document Library".  Mon élément reste invisible dans Share.
Est-ce que quelqu'un aurait une idée ?

Merci
9 Replies
Member II

Re: Pas d'accès au document librairy

Bonjour,

Cela ressemble fortement à un problème navigateur/flash. Quel navigateur utilisez vous ? Quelle est la version du plugin flash ? Des bruits courent  pour dire que suivant l'OS, le pluging Flash ne donne pas toujours le même résultat.


Si vous désactivez tout ce qui ressemble à un plugin flash dans votre navigateur (y compris shockwave for Director) est ce que cela va fonctionne ? Cela devrait, hormis la prévisualisation du document.
Member II

Re: Pas d'accès au document librairy

Bonjour,

Cela ressemble fortement à un problème navigateur/flash. Quel navigateur utilisez vous ? Quelle est la version du plugin flash ? Des bruits courent  pour dire que suivant l'OS, le pluging Flash ne donne pas toujours le même résultat.


Si vous désactivez tout ce qui ressemble à un plugin flash dans votre navigateur (y compris shockwave for Director) est ce que cela va fonctionne ? Cela devrait, hormis la prévisualisation du document.

Bonjour en effet cela fonctionne !
Je vous remercie.

Je vais mettre à jour ces pluggin j'espère que ca marchera
Member II

Re: Pas d'accès au document librairy

Je suis sous vista avec firefox 3 et flash 10 j'ai mis à jour avec la dernière version de flash puis downgradé en 9. Rien n'y a fait.
La seule solution que j'ai à l'heure actuelle c'est d'utiliser le moteur d'IE   :/
Active Member

Re: Pas d'accès au document librairy

Si "je n'arrive pas à utiliser le "Document Library" veut dire que rien ne fonctionne (sans rapport avec l'upload donc), ce n'est pas lié à flash (qui ne sert qu'en upload).
De plus il n'y a pas de problèmes Flash recensés sous Windows pour le moment, les chances (ou la malchance) que ce soit lié sont donc faibles.

Ce qui a été vu plusieurs fois par contre, c'est un réglage un peu agressif d'extensions firefox de type "addblock" ou bien "noscript".
Regarde si tu utilises ce genre d'extension, et essaye de les activer/désactiver.
Member II

Re: Pas d'accès au document librairy

i "je n'arrive pas à utiliser le "Document Library" veut dire que rien ne fonctionne (sans rapport avec l'upload donc), ce n'est pas lié à flash (qui ne sert qu'en upload)

Ce qui a été vu plusieurs fois par contre, c'est un réglage un peu agressif d'extensions firefox de type "addblock" ou bien "noscript".

Objections Votre Honneur,

Chez moi, sur une Debian tout ce qu'il y a de plus classique, et son ersatz de Firefox 3.06 :

– "Ad Block plus" activé, les règles de Filterset appliquées et pas de plugin flash activé. J'ai accès à la liste des documents de "Document Library". Je vois les prévisualisations en vignette. Les boutons "New Folder" et "Upload" sont actifs. L'"Upload" ne marche pas. Les menus sont bien actifs à chaque survol de documents.
– Je garde "Ad Block", j'active "Shockwave Flash 10.0.r12", je ne vois plus les documents, les boutons sont tous grisés.
– Toujours avec "Ad Block", j'active "Shockwave Flash 10.0.r15", j'ai un comportement à peu près normal. Les documents sont visibles, les boutons actifs. L'"Upload" ne marche toujours pas.
– Maintenant, sans "Ad Block", et avec ou sans "Shockwave 10.0.r12" et "Shockwave 10.0.r15", voir les deux en même temps, j'ai le comportement à peu près normal. Seul l'"Upload" ne marche pas, mais le bouton est actif.

Dans tous les cas, j'ai au mieux la prévisualisation en vignette, mais jamais l'aperçu du document sur la page des détails.

J'ai constaté grosso modo le même comportement avec un poste sous XP avec le trio Shockwave for Director, flash 9 et ou 10 et Ad Block.

Donc, Votre Honneur, s'il est indéniable qu'Ad Block a sa part de responsabilité dans tout ça, j'ai la très nette impression que Flash n'est pas totalement innocent.
Active Member

Re: Pas d'accès au document librairy

Objection accordée.
Greffier, veuillez noter l'objection de Maitre Patrice.

L'idéal serait d'ajouter ces résultats à https://issues.alfresco.com/jira/browse/ALFCOM-2593 (pas sûr que le greffier le fasse sinon  :wink: ).
Member II

Re: Pas d'accès au document librairy

Bonjour,

Même problème avec une cause originelle un peu différente.

Suite à un changement du profil admin, changement du nom et prénom, l'ensemble des documents anciennement uploadé par ce dernier ont disparus de l'interface Share. Les documents uploadé par les autres utilisateurs ont également disparus.

Via Explorer je constate qu'ils sont tous là, mais invisible sous share. Les images présentes ne sont plus chargées dans le wiki et la document library ne les montrent plus non plus.

J'ai relancé Alfresco avec l'option index.recovery.mode=FULL mais cela n'a rien changé.

Après 3 relances en mode FULL mes documents sont enfin revenus par contre le user "admin" n'existe plus en base.
En se connectant  avec un autre user administrateur sous Explorer, le user 'admin' est toujours là mais ne peut être modifié. A la sauvegarde Alfresco indique que l'utilisateur n'a pas été trouvé en base.


Des idées ?

Merci
Member II

Re: Pas d'accès au document librairy

L'idéal serait d'ajouter ces résultats à https://issues.alfresco.com/jira/browse/ALFCOM-2593 (pas sûr que le greffier le fasse sinon :wink: ).

Je viens de mettre à jour la main courante.
Member II

Re: Pas d'accès au document librairy

Bonsoir à tous,
Effectivement la désactivation d'ABP à résolu mon problème.

Merci Smiley Wink