Problema en la busqueda

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
mercucho1
Member II

Problema en la busqueda

Hola! Estoy empezando a meter mano a alfresco y hay una cosilla que no logro hacer. Resulta que he creado un contenido personalizado, y a traves de la busqueda avanzada, me busca pero solo me lo encuentra si lo que escribo coincide al 100% con el contenido de la propiedad.

Por ejemplo, un campo en cuestión que se llama "resumen". Tengo un contenido cuyo valor resumen es "historia de una persona". Si busco "historia" (sin comillas) no me aparece resultados, si busco "persona" tampoco, pero si busco exactamente "historia de una persona" si que me aparece.

Os pongo el extracto del customModel.xml

            <property name="custom:inventarioResumen">
               <title>Resumen</title>
               <type>d:text</type>
               <mandatory>true</mandatory>
               <index enabled="true">
                  <atomic>true</atomic>
                  <stored>false</stored>
                  <tokenised>false</tokenised>
               </index>               
            </property>

y el del web-client-config-custom.xml
   <config evaluator="string-compare" condition="Advanced Search">
      <advanced-search>
         <custom-properties>
            <meta-data aspect="custom:inventario" property="custom:inventarioResumen" />
         </custom-properties>
      </advanced-search>
   </config>   

Le ha dado un monton de vueltas a las busquedas, pero no logro dar con la tecla. ¿Alguien podría orientarme un poco?
6 Replies
mercucho1
Member II

Re: Problema en la busqueda

una ayudita pleaseee
mercucho1
Member II

Re: Problema en la busqueda

alguna idea? no puedo hacer busqueda en los aspectos Smiley Sad
cybermakoki
Member II

Re: Problema en la busqueda

Nos puedes poner por favor, la búsqueda que haces?? yo lo tengo hecho así, y me funciona bien:

@dm\:MiPropiedad:"*TEXTO*" 

prueba a ver y nos dices algo Smiley Happy
mercucho1
Member II

Re: Problema en la busqueda

Nos puedes poner por favor, la búsqueda que haces?? yo lo tengo hecho así, y me funciona bien:

@dm\:MiPropiedad:"*TEXTO*" 

prueba a ver y nos dices algo Smiley Happy

si!! funciona!! No había caido en el tema de los comodines. Al realizar la busqueda como "*persona*" ya me aparece  Smiley Very Happy

muchas gracias por la ayuda
cybermakoki
Member II

Re: Problema en la busqueda

nada hombre! pa eso estamos!
cmarguello
Member II

Re: Problema en la busqueda

Hay alguna forma de no tener que colocar los comodines en la búsqueda?

Gracias