probleme avec alfresco

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

probleme avec alfresco

bonjour
je suis débutant dans le développement avec alfresco, je suis en stage et on m'a demandé de développer avec alfresco, tout marchait bien, je la'ai installé hier sur mon pc et ca a marché lorsque je tape l'adresse mais aujourd'hui lorsque je le démarre la fenetre du ms-dos s'affiche rien que 2seconde et alfresco ne demarre pas, je ne sais pas pourquoi il ne veut plus demarrer, et j'ai j'ai lance l'exemple d'execution SDK FirstFoundationClient et eclipse me donne ces erreurs:
Exception in thread "main" org.springframework.beans.factory.CannotLoadBeanClassException: Error loading class [org.alfresco.filesys.repo.ContentDiskDriver] for bean with name 'contentDiskDriver' defined in class path resource [alfresco/network-protocol-context.xml]: problem with class file or dependent class; nested exception is java.lang.NoClassDefFoundError: org/alfresco/jlan/server/filesys/DiskInterface
Caused by: java.lang.NoClassDefFoundError: org/alfresco/jlan/server/filesys/DiskInterface
   at java.lang.ClassLoader.defineClass1(Native Method)
   at java.lang.ClassLoader.defineClass(Unknown Source)
   at java.security.SecureClassLoader.defineClass(Unknown Source)
   at java.net.URLClassLoader.defineClass(Unknown Source)
   at java.net.URLClassLoader.access$000(Unknown Source)
   at java.net.URLClassLoader$1.run(Unknown Source)
   at java.security.AccessController.doPrivileged(Native Method)
   at java.net.URLClassLoader.findClass(Unknown Source)
   at java.lang.ClassLoader.loadClass(Unknown Source)
   at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
   at java.lang.ClassLoader.loadClass(Unknown Source)
   at org.springframework.util.ClassUtils.forName(ClassUtils.java:183)
   at org.springframework.beans.factory.support.AbstractBeanDefinition.resolveBeanClass(AbstractBeanDefinition.java:317)
   at org.springframework.beans.factory.support.AbstractBeanFactory.resolveBeanClass(AbstractBeanFactory.java:1044)
   at org.springframework.beans.factory.support.AbstractBeanFactory.isBeanClassMatch(AbstractBeanFactory.java:1072)
   at org.springframework.beans.factory.support.DefaultListableBeanFactory.getBeanNamesForType(DefaultListableBeanFactory.java:165)
   at org.springframework.context.support.AbstractApplicationContext.getBeanNamesForType(AbstractApplicationContext.java:691)
   at org.springframework.context.support.AbstractApplicationContext.invokeBeanFactoryPostProcessors(AbstractApplicationContext.java:395)
   at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:328)
   at org.springframework.context.support.ClassPathXmlApplicationContext.<init>(ClassPathXmlApplicationContext.java:92)
   at org.springframework.context.support.ClassPathXmlApplicationContext.<init>(ClassPathXmlApplicationContext.java:77)
   at org.alfresco.util.ApplicationContextHelper.getApplicationContext(ApplicationContextHelper.java:55)
   at org.alfresco.sample.FirstFoundationClient.main(FirstFoundationClient.java:69)
Caused by: java.lang.ClassNotFoundException: org.alfresco.jlan.server.filesys.DiskInterface
   at java.net.URLClassLoader$1.run(Unknown Source)
   at java.security.AccessController.doPrivileged(Native Method)
   at java.net.URLClassLoader.findClass(Unknown Source)
   at java.lang.ClassLoader.loadClass(Unknown Source)
   at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
   at java.lang.ClassLoader.loadClass(Unknown Source)
   at java.lang.ClassLoader.loadClassInternal(Unknown Source)
   … 23 more
merci de votre aide
et derniere question qu'est ce que je dois avoir lorsque j'execute FirstFoundationClient??
merci
3 Replies
Highlighted
Member II

Re: probleme avec alfresco

Bonjour,

Je suis désolé je ne peux pas répondre à ton problème.

Par contre je vais m'appuyer sur ta  dernière question.

Quel résultat doit on voir apparaitre lors du lancement de FirstFoundationClient ?

Dans mon cas la compilation avec Eclipse se passe bien, par contre je ne peux pas la page Alfresco sur http://localhost:8080/alfesco

Voici le log


16:52:17,945 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco JVM - v1.5.0_09-b03; maximum heap size 63,563MB
16:52:17,945 WARN  [org.alfresco.service.descriptor.DescriptorService] Alfresco JVM - WARNING - maximum heap size 63,563MB is less than recommended 512MB
16:52:17,945 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco started (Community Network): Current version 2.1.0 (482) schema 64 - Installed version 2.1.0 (482) schema 64

J'ai à mon avis du oublier ou ne pas faire attention à un "détail" en cours de route.

Ptitmat
Highlighted
Member II

Re: probleme avec alfresco

Bonjour,

Je me permets de compléter mon message d'hier car je vois bien apparaitre le fichier maintenant.  Je me permets de mettre en ligne les modifications si cela peut être utile à quelqu'un d'autres.

J'ai apporté quelques modifications sur les fichiers en décommentant le fcihier custom-repository dans eclipse


#
# Sample custom content and index data location
#

dir.root=C:/alfresco/alf_data


db.username=alfresco
db.password=alfresco

#
# MySQL connection (This is default and requires mysql-connector-java-3.1.12-bin.jar, which ships with the Alfresco server)
#

db.driver=org.gjt.mm.mysql.Driver
db.url=jdbc:mysql://localhost/alfresco

#
# Oracle connection (requires ojdbc14_g.jar or equivalent jar in shared libraries location)
#
#db.driver=oracle.jdbc.OracleDriver
#db.url=jdbc:oracle:thin:@localhost:1521:alfresco

#
# Sybase connection (requires jconn2d.jar or equivalent jar in shared libraries location)
#
#db.driver=com.sybase.jdbc2.jdbc.SybDriver
#db.url=jdbc:sybase:Tds:localhost:2638/alfresco

Lors de la compilation avec eclipse (run FirstFoundationClient), j'obtiens dans la console le message suivant :


10:20:22,724 ERROR [transform.magick.AbstractImageMagickContentTransformer] ImageMagickContentTransformer not available: Failed to perform ImageMagick transformation:
Execution result:
   os:         Windows XP
   command:    imconvert "C:\DOCUME~1\mbourqui\LOCALS~1\Temp\Alfresco\ImageMagickContentTransformer_init_source_59355.gif"  "C:\DOCUME~1\mbourqui\LOCALS~1\Temp\Alfresco\ImageMagickContentTransformer_init_target_59356.png"
   succeeded:  false
   exit code:  1
   out:       
   err:        CreateProcess: imconvert "C:\DOCUME~1\mbourqui\LOCALS~1\Temp\Alfresco\ImageMagickContentTransformer_init_source_59355.gif" "C:\DOCUME~1\mbourqui\LOCALS~1\Temp\Alfresco\ImageMagickContentTransformer_init_target_59356.png" error=2
10:20:24,974 WARN  [remoting.rmi.RmiRegistryFactoryBean] Could not detect RMI registry - creating new one
10:20:26,786 WARN  [alfresco.util.OpenOfficeConnectionTester] A connection to OpenOffice could not be established.
10:20:29,833 INFO  [domain.schema.SchemaBootstrap] Schema managed by database dialect org.hibernate.dialect.MySQLInnoDBDialect.
10:20:29,958 INFO  [domain.schema.SchemaBootstrap] Executing database script C:\DOCUME~1\mbourqui\LOCALS~1\Temp\Alfresco\AlfrescoSchemaCreate-org.hibernate.dialect.MySQLInnoDBDialect-59357.sql (Generated).
10:21:11,660 INFO  [domain.schema.SchemaBootstrap] Executing database script C:\DOCUME~1\mbourqui\LOCALS~1\Temp\Alfresco\AlfrescoSchemaUpdate-org.hibernate.dialect.MySQLInnoDBDialect-59358.sql (Copied from classpath:alfresco/dbscripts/create/2.1/org.hibernate.dialect.MySQLInnoDBDialect/AlfrescoPostCreate-2.1-FKIndexes.sql).
10:21:12,066 INFO  [domain.schema.SchemaBootstrap] All executed statements written to file C:\DOCUME~1\mbourqui\LOCALS~1\Temp\Alfresco\AlfrescoSchemaUpdate-All_Statements-59359.sql.
10:22:38,313 INFO  [repo.admin.ConfigurationChecker] The Alfresco root data directory ('dir.root') is: C:\alfresco\alf_data
10:22:38,329 INFO  [admin.patch.PatchExecuter] Checking for patches to apply …
10:22:38,485 INFO  [repo.module.ModuleServiceImpl] Found 0 module(s).
10:22:38,563 INFO  [service.descriptor.DescriptorService] Alfresco JVM - v1.5.0_09-b03; maximum heap size 63,563MB
10:22:38,563 WARN  [service.descriptor.DescriptorService] Alfresco JVM - WARNING - maximum heap size 63,563MB is less than recommended 512MB
10:22:38,563 INFO  [service.descriptor.DescriptorService] Alfresco started (Community Network): Current version 2.1.0 (482) schema 64 - Installed version 2.1.0 (482) schema 64

Je ne sais pas s'il est normal d'obtenir : Found 0 module(s).

Ensuite je lance à partir des commandes mon alfresco.
Je me connecte en admin et je regarde dans le dossier Compagny Home .

Je laisse au connaisseur l'honneur de rectifier tous les points flous ou inexact pour éciter d'induire en erreur. Mais cette config fonctionne chez moi.

A bientôt pour de nouvelles questions
Ptitmat
Highlighted
Member II

Re: probleme avec alfresco

Merci beaucoup pour vos réponses
je suis arrivé à résoudre mon problème
merci
cordialement