[Résolu] bouton ok grisé..bug ?

cancel
Showing results for 
Search instead for 
Did you mean: 
Member II

[Résolu] bouton ok grisé..bug ?

Bonjour,

Je suis actuellement en train de tester alfresco, et je souhaite créer un workflow simple en m'inspirant du guide PDF("getting started").
Dans l'assistant après avoir configuré les dossiers à utiliser en cas de refus ou d'approbation, le bouton "ok" reste grisé et je ne peux donc pas valider mon workflow. Ca ressemble à un bug, mais il s'agit peut être d'une mauvaise manipulation de ma part.
Voici une capture d'écran :
[img]http://img366.imageshack.us/img366/1445/boutonokkz2.th.jpg[/img]

Comme vous pouvez le voir le bouton ok est resté grisé.
Je suis en local sur windows 2000, j'utilise IE 6, car avec firefox 3.0.1 la sélection des dossiers ne fonctionne pas.
Pour la version d'alfresco, j'avoue que je suis un peu perdu, d'après le readme, il s'agit de la version 2.1, mais d'après le fichier d'intallation il s'agit de la version 2.9.0B (community), ce qui me semble plus logique car le "getting started" pour la 2.1 ne correspond pas tout à fait avec la version que j'utilise.

bug ou mauvaise utilisation ?
3 Replies
Member II

Re: [Résolu] bouton ok grisé..bug ?

Bonjour,

il y a en effet un bug à ce sujet…
Editez le fichier simple-workflow.jsp du dossier alfresco\jsp\actions\

Ligne 261, modifiez comme suit :

<td align="center">
<%–
<h:commandButton id="ok-button" value="#{msg.ok}" action="#{WizardManager.bean.addAction}"
styleClass="wizardButton" disabled="true" />
–%>
<h:commandButton id="ok-button" value="#{msg.ok}" action="#{WizardManager.bean.addAction}"
styleClass="wizardButton" disabled="#{WizardManager.bean.actionProperties.approveFolder == null}" />
</td>

ça devrait aller…
cf :
http://forums.alfresco.com/en/viewtopic.php?f=12&t=10156&p=33691&hilit=bug+workflow+button#p33691

Cordialement…
Member II

Re: [Résolu] bouton ok grisé..bug ?

effectivement ça corrige le problème, merci Smiley Happy
Member II

Re: [Résolu] bouton ok grisé..bug ?

d'ailleur, je l'ai souligné, mais je le repette, avec firefox 3.0.1, la sélection des dossier à déplacer ds le workflow ne fonctionne pas.