[Résolu] Disparition TOMCAT avec ALFRESCO 3.3

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

[Résolu] Disparition TOMCAT avec ALFRESCO 3.3

Si votre fenêtre TOMCAT disparait au bout de 1 à 2 secondes après un démarrage de ALFRESCO Community ou Enterprise, voici une solution pour y remédier :

Je me suis aperçu qu'en lançant directement le STARTUP.BAT de la 3.3 la fenêtre restait même si l'initialisation était incorrecte.
J'en ai donc déduit que l'erreur était provoquée par un script en amont. J'ai modifié ALFRESCO.BAT pour mettre les options JVM
de la 3.2 et la bingo, cela a fonctionné.

Options 3.2
set JAVA_OPTS=-Xms128m -Xmx512m -Xss96k -XX:MaxPermission=160m -server -Dalfresco.home=%ALF_HOME -Dcom.sun.management.jmxremote

Options 3.3
set JAVA_OPTS=-Xms512m -Xmx1024m -Xss1024k -XX:MaxPermission=160m -XX:NewSize=256m -server -Dalfresco.home=%ALF_HOME -Dcom.sun.management.jmxremote

Dans 9 mois c'est la retraite, je prendrais donc à ce moment là, le temps de tester paramètre par paramètre, désolé, mais, un peu à vous de vous "amuser"…

J'espère que cette "solution" aidera quelqu'un, car moi, j'en ai vraiment bavé…
4 Replies
Highlighted
Active Member

Re: [Résolu] Disparition TOMCAT avec ALFRESCO 3.3

Quelle est la config matérielle du serveur sur lequel vous avez votre installation ? de combien de RAM dispose-t-il ? est il mutualisé avec d'autres applications ?
Il semblerait que vous ne puissiez donc pas allouer les 512Mo minimum pour la JVM (-Xms512m).
Highlighted
Member II

Re: [Résolu] Disparition TOMCAT avec ALFRESCO 3.3

J'ai testé sur un portable ACER avec 2 Go de RAM.
Cette config est tout ordinaire : WIN7 avec Ofiice Intégrale 2007 plus Outlook 2007, ce dernier n'étant pas actif lors des tests, IE8 et un anti-virus.
Aucune application ne tourne dessus, c'est un PC personnel et non professionnel.
Highlighted
Active Member

Re: [Résolu] Disparition TOMCAT avec ALFRESCO 3.3

Probable donc que la stack size à 96k que vous avez initialement choisiene soit pas suffisante. On pourrait le vérifier dans les logs s'il y a des exceptions de type "StackOverflowError" mais vous ne les avez pas publiés. Enlever ce paramètre l'a remis à sa valeur par défaut (320k pour des machines 32bit, 1024k pour des machines 64bit).
Highlighted
Member II

Re: [Résolu] Disparition TOMCAT avec ALFRESCO 3.3

Je n'ai pris aucune décision quant aux paramètres : j'ai pris ceux mis de base dans l'installation.

Si le Stack Size est le paramètre Xss, 96K semble suffisant puisque j'ai pris les définitions initiales de la 3.2 pour démarrer en 3.3