[RESOLU] problème importation des catégories dans un ACP

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member

[RESOLU] problème importation des catégories dans un ACP

Bonjour

Je suis en cours de test sur un import ACP de document portant des catégories.

Lors de l'import les catégories ne sont pas récupérées pourtant le dossier où j'effectue l'import j'ai mis une règle que rend catégorisable tous les fichier entrant.
Malgré tout aucune catégorie n'est récupérée. Les catégories sont bien existantes dans alfresco.

quelqu'un a-t-il constaté le problème ????

Version testé la 3.3g community sur une plateforme windows XP
3 Replies
Highlighted
Active Member

Re: [RESOLU] problème importation des catégories dans un ACP

As tu comparé un ACP exporté d'Alfresco de noeuds portant des catégories, et un ACP que tu importes ?
Highlighted
Active Member

Re: [RESOLU] problème importation des catégories dans un ACP

Bonjour

Merci Romain de ta réponse.

Ma procédure de test effectuée est la suivante :
1. J'exporte un espace avec des documents liés à des catégorie dans un ACP.
2. Après récupération de l'ACP, Je supprime l'espace et les documents d'Alfresco.
3. Je réimporte l'ACP dans un autre espace
4. je constate que l'espace et les documents sont bien réimportés mais aucune catégorie liée aux document n'est récupérée (pourtant les catégories sont bien présentent dans l'ACP).

Existe-t-il un moyen de corrigé le problème ???

Le test est effectué sur la dernière version community la 3.3g sur un serveur XP.
Highlighted
Active Member

Re: [RESOLU] problème importation des catégories dans un ACP

Bonjour

Je me réponds à moi même, pour vous donner une astuce permettant de répondre au problème de l'importation des ACP dans Alfresco  Smiley Very Happy .

Il y a une erreur lors de l'exportation des ACP au niveau de la structuration des catégories.

Voici la syntaxe généré par les export pour la partie carégorie :
          <cm:categories>
              <view:values>
                <view:value>/cm:generalclassifiable/cm:ALFRESCO</view:value>
              </view:values>
            </cm:categories>

Il manque la structure suivante en début de déclaration de la value : /cm:categoryRoot. voici le code corrigé
          <cm:categories>
              <view:values>
                <view:value>/cm:categoryRoot/cm:generalclassifiable/cm:ALFRESCO</view:value>
              </view:values>
            </cm:categories>

Il faudra donc ajouter pour chaque <view:value> des catégories le code suivant : /cm:categoryRoot

Mes tests ont été effectués sur la version community 3.3g d'Alfresco, OS: Mandriva 2010.1, bddSmiley Tongueostgresql8.4