[RESOLU] Probleme - Déplacer contentstore

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member

[RESOLU] Probleme - Déplacer contentstore

OS: CentOs 6.5
Version Alfresco: 4.2c (Communauté)

J'ai fais une installation sur une machine virtuel et tous fonctionne correctement.  Cependant la partition /opt commence a grossir de plus en plus et il ne me reste que quelques Go de libre.  Je voudrais donc transférer le Alf_Data sur une autre partition (Style un NAS).

Je sais qu'il faut modifier le chemin du Dir.root sur le fichier
/opt/alfresco-4.2.c/tomcat/shared/classes/alfresco-global.properties

J'ai donc modifié la ligne comme ceci: dir.root=/mnt/alf_data et j'ai fais un mount pour que cela soit actif sur le NAS.

Je déplace alors que le contentstore et le contentstore.deleted puis je redémarrage les services d'Alfresco.

Je peux voir la page mais je n'arrive pas a me connecter, comme s'il avait perdu les user et meme le login/password de mon compte admin.

J'aimerais savoir si j'ai fais de la bonne façon ou s'il y a une meilleur façon de déplacer le Alf_Data, je sais qu'il a beaucoup de sujet sur le cas mais je n'ai rien trouver qui explique de façon clair et facile.

Merci beaucoup.
6 Replies
Highlighted
Active Member

Re: [RESOLU] Probleme - Déplacer contentstore

Le plus simple c'est de ne pas modifier le fichier alfresco-global.properties, mais plutôt de faire un lien direct sur les contentstores sur votre NAS.
Donc transférez les données et mettez en place les liens qui vont bien.

Cela sera transparent pour Alfresco et vous n'aurez plus de problème de place.
Highlighted
Active Member

Re: [RESOLU] Probleme - Déplacer contentstore

Donc si je comprends bien.

1: Monter la partition du Nas sur le serveur d'Alfresco
2: Faire un lien symbolique entre le contentstore et le mount et hop ?
Highlighted
Active Member

Re: [RESOLU] Probleme - Déplacer contentstore

Voici mes étapes.

- Création d'un répertoire sur le /mnt/
- Monté un repertoire du NAS sur le /mnt
- Déplacement des répertoire contentstore et contentstore.deleted sur le NAS
- Création des liens symbolique du repertoire alf_data d'alfresco vers le NAS
[img]http://i.imgur.com/3d1HVsV.png[/img]
- Reboot du serveur



[img]http://i.imgur.com/b13pP0D.png[/img]

Puis j'ai toujours l'erreur du login qui ne fonctionne pas Smiley Sad
Highlighted
Active Member

Re: [RESOLU] Probleme - Déplacer contentstore

J'ai recommencer et ceci a fonctionner… je vais recommencer pour etre certain que cela fonctionne et je vais inscrire les étapes par la suite si cela fonctionne !
Highlighted
Active Member

Re: [RESOLU] Probleme - Déplacer contentstore

Cela fonctionne, voici donc les étapes a suivre pour déplacer Contentstore et Contentstore.deleted sur un NAS

  • 1: Création d'un dossier sur le /mnt

  • mkdir /mnt/Alfresco

  • 2: Monté le NAS sur le serveur d'Alfresco

  • mount -t cifs //ip_du_nas/TestAlfresco /mnt/Alfresco -o username=votre_user,password=votre_password,rw

  • 3: Fermer le serveur d'Alfresco

  • service alfresco stop

  • 4: Une fois le serveur complétement arrêter, transférer les répertoire contentstore et contentstore.deleted sur le nas

  • 5: Supprimer le contentstore et contentstore.deleted que vous avez sur votre serveur d'Alfresco.  Dans mon cas il était situé dans /opt/alfresco/alf_data

  • 6: Faire ensuite les liens symboliques de vos deux répertoires

  • ln -s /mnt/Alfresco/contentstore /opt/alfresco/alf_data/contentstore
    ln -s /mnt/Alfresco/contentstore.deleted/ /opt/alfresco/alf_data/contentstore.deleted

    7: Redémarrer le serveur Alfresco
    service alfresco start
ET HOP ! Le tour est joué
Un grand merci a jeanjot pour la piste a suivre.

PS: Ne pas oublier de faire en sorte que le mount du NAS soit fait automatiquement en cas de redémarrage du serveur.
Highlighted
Active Member

Re: [RESOLU] Probleme - Déplacer contentstore

De rien et bon courage pour la suite.
Et merci d'avoir pris le temps de détailler la procédure.

JeanJo