Salut,Après quelques recherches sur les forums,...

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

Salut,Après quelques recherches sur les forums,...

Salut,

Après quelques recherches sur les forums, j'ai pu voir que dans le module WCM d'Alfresco, pour l'édition de contenu Web, si l'on désire ajouter une image, il est possible de naviguer dans le repository. Savez vous comment cela a été réalisé (de quel façon TinyMCE a été paramétré) car j'aimerais réutiliser cette fonctionnalité pour la création de contenu normal (je dois pas être le seul) ?

Merci d'avance


Nico
5 Replies
Highlighted
Active Member

Re: Salut,Après quelques recherches sur les forums,...

Il y a un projet de la forge qui permet de faire ça : Web UI Widget and Component Pack (http://forge.alfresco.com/projects/ui-widgets/)
Highlighted
Member II

Re: Salut,Après quelques recherches sur les forums,...

Oui, je sais (grace à l'un de tes posts d'ailleurs) mais je n'ai malheureusement pas réussi à l'utiliser. L'installation s'est bien déroulée apparemment. Mais aucun changement dans le client web.

As tu réussi à le faire fonctionner ?
Highlighted
Active Member

Re: Salut,Après quelques recherches sur les forums,...

Bonjour,

Ce projet ne marchait pas mais il a été mis à jour très récemment (le 19/07 pour être exact) pour être compatible avec les versions 2.0 et 2.1 d'Alfresco. Quand l'as-tu essayé pour la dernière fois ?
Highlighted
Member II

Re: Salut,Après quelques recherches sur les forums,...

Hier, mais c'est peut être dû simplement à mon incompétence Smiley Sad
Highlighted
Active Member

Re: Salut,Après quelques recherches sur les forums,...

Bonjour,

En fait je n'utilise pas directement le code source de la Forge. J'ai récupéré celui qui était basé sur Alfresco 1.4 mais qui ne marchait pas et je l'ai migré en 2.1. Ca marche chez moi mais je ne l'ai pas commité sur la Forge car l'administrateur du projet l'a fait avant moi (manque de communication !). Je n'ai pas vérifié si sa version marchait mais en faisant un diff de mes sources et des siens il n'y a pas beaucoup de différences, si ce n'est une transformation d'un chemin absolu un peu bizarre. Quand j'aurai le temps je lui proposerai un fix si c'est ça qui pose problème (par exemple à cause de la traduction "Company Home" -> "Alfresco" dans les installs françaises).
Si tu veux je peux t'envoyer ma version qui marche, mais je ne veux pas écraser la version SVN de la forge sans m'être synchronisé avec l'admin du projet.