Update de la version 2.9 à 3.4 Community

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

Update de la version 2.9 à 3.4 Community

Bonjour,

je dois mettre à jour notre version d'Alfresco (2.9) vers la dernière version 3.4. J'ai lu les différents wiki, aides, forums (FR et EN) mais j'ai encore quelques doutes.

Comme c'est une version 2.9, je pense que je dois passer par une version intermédiaire avant de passer à la 3.4 : laquelle ?  Je n'ai pas trouvé de réponse dans la section "Alfresco upgrade paths" de l'aide.
Puis, on m'a dit que je pouvais faire un export dans Alfresco 2.9 puis qu'il suffisait de faire un import dans la version 3.4, mais dans le Wiki, cela est fortement déconseillé.

Je pensais donc suivre la procédure d'upgrade qui consite à sauvegarder le dossier alf_data et la base de données, puis de les copier dans le dossier de la nouvelle installation.

Quelle solution choisir pour réaliser l'upgrade ?

Merci d'avance.
10 Replies
Highlighted
Member II

Re: Update de la version 2.9 à 3.4 Community

J'ai une deuxième question :
J'ai lu que l'on ne pouvait faire au maximum que deux upgrade intermédiaire.

Donc, si ma version a déjà été upgradée deux fois (par exemple 2.1 -> 2.5 et 2.5 ->2.9) est-ce que je pourrai à nouveau passer de 2.9 -> 3.2 puis 3.2 -> 3.4 ?

Merci.
Highlighted
Member II

Re: Update de la version 2.9 à 3.4 Community

Up :

je suis un peu perdu, je ne sais pas si je dois passer par la 3.2 ou la 3.2r ou la 3.2r2.

Quelqu'un peut m'aider ?

Merci.
Highlighted
Active Member

Re: Update de la version 2.9 à 3.4 Community

J'ai lu que l'on ne pouvait faire au maximum que deux upgrade intermédiaire.
Gni ? Je ne comprends pas ce concept. Après 3 upgrades il se passe quoi ?
Comme c'est une version 2.9, je pense que je dois passer par une version intermédiaire avant de passer à la 3.4 : laquelle ? Je n'ai pas trouvé de réponse dans la section "Alfresco upgrade paths" de l'aide.
Et pour cause, la version 2.9 n'existe pas dans la liste des versions officielles. C'était une version intermédiaire, qu'il était conseillé de ne pas utiliser autrement que pour donner son avis sur des développements intermédiaires. Il y a d'ailleurs des choses qui existent en 2.9 et seulement en 2.9. De fait vous êtes un peu tout seul là.

Essayez toujours de passer par la version supérieure la plus proche (3.0), mais c'est sans garantie aucune. Vous allez devoir trouver le chemin seul, et certainement mettre les mains dans le cambouis. Considérez ça comme un projet de migration plutôt que comme une mise à jour, ce sera sans doute moins douloureux.
Highlighted
Member II

Re: Update de la version 2.9 à 3.4 Community

Tout d'abord merci pour votre réponse.

Pour le nombre d'upgrades, j'avais mal compris.

J'avais commencé à passer à la version 3.2r2.
je vais voir si je peux installer rapidement la 3.0, mais si je dois ensuite passer par la 3.2r2 puis enfin arriver à la 3.4, je crois que je vais mettre les fichiers un par un avec leur droit sur une version d'alfresco 3.4 toute propre !

Merci.

Edit : Est-ce que la version 3.4.d est une version majeure ou alors une version d'essai comme la 2.9 ? Parce que je voudrais éviter de reproduire la même erreur.
Highlighted
Active Member

Re: Update de la version 2.9 à 3.4 Community

La 2.9 est la seule avec ce statut particulier (intermédiaire entre 2 et 3).
La dernière version de référence est la 3.4.d.
Highlighted
Member II

Re: Update de la version 2.9 à 3.4 Community

Bonjour,

j'ai installé une version propre d'Alfresco 3.4.d, et je l'ai enfin paramétrée.

Maintenant, il me reste à remettre toutes les données présentes dans la version 2.9.

Le problème est que l'export échoue à chaque fois. Je dois avoir une trentaine de gigaoctets de données.

Est-ce que quelqu'un sait comment je pourrais importer mes données ? Ou est-ce impossible ?

Merci  Smiley Happy
Highlighted
Active Member

Re: Update de la version 2.9 à 3.4 Community

Bonjour

y-aurait bien eu la possibilité de passer par des ACP (Alfresco Content Package), mais depuis la version 3.4.c ou d, l'importation des catégories ne fonctionne plus.

En tout cas dans la version Community : http://issues.alfresco.com/jira/browse/ALF-7180

A quand, une résolution dans Alfresco Community ?????
Highlighted
Member II

Re: Update de la version 2.9 à 3.4 Community

Merci pour votre réponse.

Tant pis si ça ne fonctionne plus, car de toute manière dans ma version 2.9, les ACP (ce que j'ai appelé "l'export") ne fonctionnent pas.

Enfin bon, j'aurais pû m'en servir pour passer de la version 2.9 à 3.2 puis ensuite j'aurais copié mon alf_data et la base de donnée dans la version 3.4.d.
Mais comme entre temps j'ai aussi changé la version de postgres, pas sûr que cela aurait marché.

Je vais essayer avec CIFS.

merci.
Highlighted
Active Member

Re: Update de la version 2.9 à 3.4 Community

Bonjour

Le problème avec CIFS c'est que vous allez perdre toutes les informations portées par les documents, comme les méta-données, les règles sur les dossiers, versionning, …

CIFS ne vous restitue que vos documents et votre organisation de dossier, tout le reste est perdu … Smiley Sad