Alfresco Debugging Custom Aspects

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

Alfresco Debugging Custom Aspects

Hallo,

ich versuche mich gerade daran meinen ersten Custom-Aspect in Alfresco zu schieben. Leider bekomme ich dabei eine Meldung alla "Invalid Aspect".

Nun gut, im Alfresco-Wiki findet man eine Beschreibung wie man mit TestModel einen Aspect bzw. Model austesten kann um zu sehen ob es valide ist….

Nach einigem hin und her mit dem schönen Classpath dann das….

java -cp ./tomcat/webapps/alfresco/WEB-INF/lib/*:tomcat/webapps/alfresco/WEB-INF/lib/alfresco-repository-3.4.b.jar org.alfresco.repo.dictionary.TestModel

Testing dictionary model definitions…
alfresco/model/dictionaryModel.xml
alfresco/model/systemModel.xml
org/alfresco/repo/security/authentication/userModel.xml
alfresco/model/contentModel.xml
alfresco/model/wcmModel.xml
alfresco/model/applicationModel.xml
alfresco/model/bpmModel.xml
alfresco/model/wcmAppModel.xml
Found an invalid model…
11080000 Could not find bootstrap model alfresco/model/dictionaryModel.xml

Wobei das nicht mein Model ist ….. args…..

Kann sich darauf einer einen Reim bilden? :-)



lg
Chris
4 Replies
Highlighted
Member II

Re: Alfresco Debugging Custom Aspects

so also mein Custom-Aspect funktioniert. Kann in einer Content-Rule den hinzufügen und sehe auch die Details in der Form…

nur das TestModel will immer noch nicht :-|

Die Datei existiert übrigens und wurde auch nicht von mir verändert!


root@ubuntu:/opt/alfresco-3.4.b# find ./ -name 'dictionaryModel.xml'
./tomcat/webapps/alfresco/WEB-INF/classes/alfresco/model/dictionaryModel.xml
Highlighted
Member II

Re: Alfresco Debugging Custom Aspects

Die Alfresco Model Files befinden sich unterhalb von ./tomcat/webapps/alfresco/WEB-INF/classes/*
Du fügst diesen Pfad jedoch beim Aufruf von TestModel nicht hinzu. Vermute es liegt daran.
Gruß
Thomas
Highlighted
Member II

Re: Alfresco Debugging Custom Aspects


root@alfresco:/opt/alfresco-3.4.b# java -cp ./tomcat/webapps/alfresco/WEB-INF/lib/*:./tomcat/webapps/alfresco/WEB-INF/classes/alfresco/*:tomcat/webapps/alfresco/WEB-INF/lib/alfresco-repository-3.4.b.jar org.alfresco.repo.dictionary.TestModel
Testing dictionary model definitions…
alfresco/model/dictionaryModel.xml
alfresco/model/systemModel.xml
org/alfresco/repo/security/authentication/userModel.xml
alfresco/model/contentModel.xml
alfresco/model/wcmModel.xml
alfresco/model/applicationModel.xml
alfresco/model/bpmModel.xml
alfresco/model/wcmAppModel.xml
Found an invalid model…
00040000 Could not find bootstrap model alfresco/model/dictionaryModel.xml



Sorry für die späte Antwort :-)


Versuch scheitert leider noch….


lg
Highlighted
Member II

Re: Alfresco Debugging Custom Aspects


java -cp ./tomcat/webapps/alfresco/WEB-INF/lib/*:./tomcat/webapps/alfresco/WEB-INF/classes:tomcat/webapps/alfresco/WEB-INF/lib/alfresco-repository-3.4.b.jar org.alfresco.repo.dictionary.TestModel

so wars dann richtig :-)

vielen dank für die hilfe!!



lg