Problemi di Installazione Alfresco 6.1

cancel
Showing results for 
Search instead for 
Did you mean: 
el_stefano
Active Member

Problemi di Installazione Alfresco 6.1

Ciao,

è la prima volta che installa Alfresco e quindi chiedo scusa in anticipo per le mie inesattezze.

Sto installando Alfresco 6.1 su CentOS7, utilizzando come DB, MariaDB sullo stesso server.

Per l'installazione ho seguito la documentazione, ho avuto qualche difficoltà dovute al fatto che non ho esperienza ma ora mi sono bloccato e non riesco ad andare avanti.

Il problema è che quando faccio partire Tomcat 9, in catalina.out vedo la seguente eccezione:

Error creating bean with name 'dialect': FactoryBean threw exception on object creation; nested exception is java.lang.IllegalArgumentException: Dialect must be explicitly set for database: MariaDB
at org.springframework.beans.factory.support.BeanDefinitionValueResolver.resolveReference(BeanDefinitionValueResolver.java:378)
at org.springframework.beans.factory.support.BeanDefinitionValueResolver.resolveValueIfNecessary(BeanDefinitionValueResolver.java:110)
at org.springframework.beans.factory.support.BeanDefinitionValueResolver.resolveManagedList(BeanDefinitionValueResolver.java:401)
at org.springframework.beans.factory.support.BeanDefinitionValueResolver.resolveValueIfNecessary(BeanDefinitionValueResolver.java:159)
at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.applyPropertyValues(AbstractAutowireCapableBeanFactory.java:1648)
at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.populateBean(AbstractAutowireCapableBeanFactory.java:1400)
at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:575)
at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:498)
at org.springframework.beans.factory.support.AbstractBeanFactory.lambda$doGetBean$0(AbstractBeanFactory.java:320)
at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:222)
at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:318)
at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:204)
at org.springframework.context.support.PostProcessorRegistrationDelegate.invokeBeanFactoryPostProcessors(PostProcessorRegistrationDelegate.java:171)
at org.springframework.context.support.AbstractApplicationContext.invokeBeanFactoryPostProcessors(AbstractApplicationContext.java:691)
at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:528)
at org.springframework.web.context.ContextLoader.configureAndRefreshWebApplicationContext(ContextLoader.java:400)
at org.springframework.web.context.ContextLoader.initWebApplicationContext(ContextLoader.java:291)
at org.springframework.web.context.ContextLoaderListener.contextInitialized(ContextLoaderListener.java:103)
at org.alfresco.web.app.ContextLoaderListener.contextInitialized(ContextLoaderListener.java:70)
at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4682)
at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5150)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:183)
at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:713)
at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:690)
at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:695)

ne riporto solo parte perchè mi sembra che poi si ripeta sempre lo stesso tipo.
ho provato a mettere nel file tomcat/shared/classes/alfresco-global.properties:

hibernate.dialect=org.hibernate.dialect.MariaDBDialect

ma niente, il risultato non cambia e non so più che cosa fare !!

Grazie in anticipo per la vostra attenzione.

Buona giornata

5 Replies
el_stefano
Active Member

Re: Problemi di Installazione Alfresco 6.1

Ciao,

il non aver avuto risposte, mi sconforta non poco !!!

Comunque, il problema era che avevo installato un connettore java per MariaDB che era troppo recente e non rientrava nelle versioni gestite dal Alfresco 6.1

Saluti

Moderator
Moderator

Re: Problemi di Installazione Alfresco 6.1

Ti sconsiglio di provare Alfresco 6.1 Community ma di tenerti sulla versione precedente più stabile e testata.

Considera che la versione Community è di fatto una versione Labs utilizzata per testare le nuove funzionalità quindi l'ultima versione è tipicamente quella più instabile.

Moderator
Moderator

Re: Problemi di Installazione Alfresco 6.1

Considera che questo è il forum della community e non il supporto Alfresco. Quindi le risposte vengono date da membri della comunità nel loro tempo libero.

Highlighted
el_stefano
Active Member

Re: Problemi di Installazione Alfresco 6.1

OK, ora proverò ad installare i pacchetti che vanno in errore e vediamo se cambia qualcosa, altrimenti provo ad installare la versione precedente.

Grazie per la risposta.

Saluti

el_stefano
Active Member

Re: Problemi di Installazione Alfresco 6.1

Si, si, lo so benissimo, il mio sconforto è dovuto al fatto che la mia azienda vuole Alfresco ma lo vuole community, non vuole pagare le licenze, e quindi il mio supporto è la community !!!

Ciao