Actualización a la última versión de LibreOffice para evitar problemas de rendimiento

cancel
Showing results for 
Search instead for 
Did you mean: 
chortels
Active Member II

Actualización a la última versión de LibreOffice para evitar problemas de rendimiento

Hola, 

Nos están reportando problemas con el proceso soffice.bin en Alfresco 5, que está corriendo sobre una versión 5.6 de CentOS. Cuando se suben e indexan documentos, este proceso está usando prácticamente la totalidad de la CPU, generando logs de gran tamaño y ocasionando problemas de rendimiento. Según lo que he leído en issues relacionadas(soffice.bin process using a lot of resources), esto se soluciona actualizando a la última versión de LibreOffice. 

Actualmente, tenemos instalada una versión antigua de LibreOffice en Alfresco5. Quisiera saber si actualizando a una nueva versión será suficiente para resolver este problema, o si por el contrario está causado por el propio software LibreOffice. 

En un directorio distinto del CentOS5.6 he instalado la última versión de LibreOffice(5.4), y a continuación he modificado el campo ooo.exe del fichero alfresco-global.properties, de manera que apunte al proceso soffice.bin de esta nueva instalación de LibreOffice (la versión antigua, de momento, sigue instalada). Sin embargo, cuando pruebo a visualizar documentos en Alfresco, el mensaje que me muestra es que el documento con extensión .docx, .xlsx, etc. no puede ser previsualizado, obligándome a descargarlo si quiero verlo. 

Es por ello que querría saber, además:

-Si la instalación de LibreOffice tiene que estar en una subcarpeta dentro de la ruta donde está instalado Alfresco.

-Dónde deben instalarse las librerías adicionales que se indican en Installing Linux libraries manually | Alfresco Documentation. Con este asunto también estoy teniendo problemas ya que al utilizar una versión tan deprecada de CentOS, el comando yum es incapaz de encontrar las librerías que debería instalar. 

Muchas gracias. 

Saludos.

15 Replies
cristinamr
Advanced

Re: Actualización a la última versión de LibreOffice para evitar problemas de rendimiento

Buenas.

Por partes:

>>En un directorio distinto del CentOS5.6 he instalado la última versión de LibreOffice(5.4), y a continuación he modificado el campo ooo.exe del fichero alfresco-global.properties, de manera que apunte al proceso soffice.bin de esta nueva instalación de LibreOffice (la versión antigua, de momento, sigue instalada).....

Esa es la forma correcta de apuntar a la nueva instalación.

>> Sin embargo, cuando pruebo a visualizar documentos en Alfresco, el mensaje que me muestra es que el documento con extensión .docx, .xlsx, etc. no puede ser previsualizado, obligándome a descargarlo si quiero verlo. 

Para verificar que está funcionando te diría que una vez lanzado Alfresco lances este comando:

ps -eaf |grep soffice

Pega aquí lo que te da. Me da que te falte alguna libreria o similar.

>> -Si la instalación de LibreOffice tiene que estar en una subcarpeta dentro de la ruta donde está instalado Alfresco.

Puedes ponerlo donde quieras siempre y cuando el usuario con el que se lance Alfresco tenga permisos sobre el directorio de LO.

>> -Dónde deben instalarse las librerías adicionales que se indican en Installing Linux libraries manually | Alfresco Documentation. Con este asunto también estoy teniendo problemas ya que al utilizar una versión tan deprecada de CentOS, el comando yum es incapaz de encontrar las librerías que debería instalar. 

Aquí vas a tener problemas ya que vas a tener que ir una a una descargándola e intalándola a mano en el servidor (es un trabajo curioso, ¿eh?).

De todas formas deberías echar un vistazo a las tecnologías compatibles con Alfresco 5 porque igual sería muchísimo más sencillo todo subiendo la versión del SO. Te dejo aquí un link para que descargues el de tu versión de Alfresco (no es lo mismo Alfresco 5.0 que 5.2): Supported Platforms | Alfresco 

Un saludo,

Cris.

--
VenziaIT: helping companies since 2005! Our ECM products: AQuA & Seidoc
douglascrp
Advanced II

Re: Actualización a la última versión de LibreOffice para evitar problemas de rendimiento

Double post  

chortels
Active Member II

Re: Actualización a la última versión de LibreOffice para evitar problemas de rendimiento

Hola Cristina, 

Gracias por tu pronta respuesta. Cuando ejecuto el comando ps -ef | grep soffice el único proceso que se ve es el del propio comando, es decir, que soffice.bin no está levantado. ¿Una vez instalado LibreOffice es necesario forzar que este proceso se levante? ¿Puede deberse a que faltan librerías? El problema está en que la documentación no especifica qué librerías necesita Alfresco para cada versión de LibreOffice. 

Gracias. Saludos!

cristinamr
Advanced

Re: Actualización a la última versión de LibreOffice para evitar problemas de rendimiento

Si es que todos hemos pasado por algo parecido. Ojea este link: Problemas con LibreOffice en un Alfresco 5.2. limpio @ Cris in the cloud 

Creo que te va a orientar sobre cómo puedes saber qué error concreto tienes. Partiendo de ahí vamos viendo.

Ve contándonos

Cris.

--
VenziaIT: helping companies since 2005! Our ECM products: AQuA & Seidoc
chortels
Active Member II

Re: Actualización a la última versión de LibreOffice para evitar problemas de rendimiento

Muchas gracias por la info, Cristina. El problema que estoy teniendo al volver a instalar LibreOffice en Alfresco (antes lo intenté con una 5.4, ahora he probado con una 5.3), es que cuando instalo el los rpm y me voy al directorio donde se han instalado y veo los ficheros que te adjunto pero, por el contrario, no encuentro el directorio scripts que contiene el fichero "libreoffice_ctl.sh", con el que puede en teoría levantarse LibreOffice. ¿Sabes a qué puede deberse? Te mando una captura con el resultado de la instalación. Sólo se instala lo que ahí se ve, y nada más. 

 

¿puede tener que ver con que en la propia instalación de Alfresco hay ya una carpeta "libreoffice", que sí contiene esta carpeta "scripts"? El caso es que esa es la instalación que quiero cambiar, pues es la que está dando problemas con el proceso soffice.bin

Saludos!

(Añado: los paquetes de LibreOffice que estoy descargando, tanto 5.4 como 5.3, son los oficiales: Download LibreOffice | LibreOffice - Free Office Suite - Fun Project - Fantastic People , en su instalación x86_64 rpm al tratarse de un CentOS, por lo que no me explico por qué esa carpeta "scripts" no aparece).

angelborroy
Alfresco Employee

Re: Actualización a la última versión de LibreOffice para evitar problemas de rendimiento

Quizá esto te sea de ayuda: http://beecon.buzz/2017/assets/files/EF09/EF09-Installing-Alfresco-components-1-by-1.pdf

En uno de los pasos se instala el servicio de LibreOffice desde cero.

Hyland Developer Evangelist
chortels
Active Member II

Re: Actualización a la última versión de LibreOffice para evitar problemas de rendimiento

Hola Ángel, 

Gracias por tu pronta respuesta. He estado revisando las diapositivas de LibreOffice y tengo una duda: ¿el fichero libreoffice.sh se crea automáticamente con la instalación o debo crearlo yo? No encuentro, en /opt/, dicho fichero. 

angelborroy
Alfresco Employee

Re: Actualización a la última versión de LibreOffice para evitar problemas de rendimiento

Debes crearlo tú.

Puedes basarte en éste: https://github.com/loftuxab/alfresco-ubuntu-install/blob/master/scripts/libreoffice.sh 

Hyland Developer Evangelist
cristinamr
Advanced

Re: Actualización a la última versión de LibreOffice para evitar problemas de rendimiento

libreoffice_ctl.sh lo único que hace es arrancar libreoffice, pararlo y ver el estado. Es como si ejecutaras esto:

libreoffice/program/soffice start

libreoffice/program/soffice stop

libreoffice/program/soffice status

Aquí te dejo varios ejemplos: Problemas con LibreOffice en un Alfresco 5.2. limpio @ Cris in the cloud 

Pero vamos, es lo que comenta Ámgel, si quieres el archivo puedes crearlo, sino puedes ejecutarlo con los comandos que te comento

--
VenziaIT: helping companies since 2005! Our ECM products: AQuA & Seidoc
Spanish User Group
“Alfresco