Buscador no muestra resultados

cancel
Showing results for 
Search instead for 
Did you mean: 
rcortesr
Active Member II

Buscador no muestra resultados

Hola,

tengo un Alfresco 6.2.1 community con docker que no muestra documentos en la búsqueda. Es un poco raro ya que solr funciona bien, he generado un informe de los índices y no hay errores. Las búsquedas desde la consola de solr también funcionan bien al igual que las búsquedas afts desde el navegador de nodos. Pero desde Alfresco share no aparecen resultados, si busco "*" solo veo 2 carpetas y el icono corporativo que he subido. En los logs no veo ningún error...

Gracias.

7 Replies
angelborroy
Alfresco Employee

Re: Buscador no muestra resultados

Puede ser un problema de permisos. ¿Estás utilizando el mismo usuario desde AFTS y desde Share?

Software Engineer in Alfresco Search Team.
rcortesr
Active Member II

Re: Buscador no muestra resultados

Hola Angel,

diría que no es un tema de permisos ya que estoy logado con el usuario admin tanto para la consulta AFTS como desde Share...

cristinamr
Intermediate II

Re: Buscador no muestra resultados

¿Has observado algún error o algo llamativo relacionado con Solr en el log al arrancar?

--
Check our products: AQuA : https://aqua.venzia.es | Seidoc : https://seidoc.es
rcortesr
Active Member II

Re: Buscador no muestra resultados

Hola Cristina,

en el log de arranque de solr vi algunos warnings pero no le di más importancia aunque quizás sí la tienen...

solr6_1               | OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
solr6_1               | 2021-05-04 03:55:59.820 INFO  (main) [   ] o.e.j.s.Server jetty-9.3.27.v20190418, build timestamp: 2019-04-18T18:11:38Z, git hash: d3e249f86955d04bc646bb620905b7c1bc596a8d
solr6_1               | 2021-05-04 03:56:05.313 INFO  (main) [   ] o.a.s.s.SolrDispatchFilter  ___      _       Welcome to Apache Solr™ version 6.6.5-patched.2 660ad3d2332b99205fbc436047f8d547511cd767 - tpage - 2019-11-27 08:18:56
solr6_1               | 2021-05-04 03:56:05.364 INFO  (main) [   ] o.a.s.s.SolrDispatchFilter / __| ___| |_ _   Starting in standalone mode on port 8983
solr6_1               | 2021-05-04 03:56:05.365 INFO  (main) [   ] o.a.s.s.SolrDispatchFilter \__ \/ _ \ | '_|  Install dir: /opt/alfresco-search-services/solr
solr6_1               | 2021-05-04 03:56:05.450 INFO  (main) [   ] o.a.s.s.SolrDispatchFilter |___/\___/_|_|    Start time: 2021-05-04T03:56:05.381867Z
solr6_1               | 2021-05-04 03:56:14.784 INFO  (main) [   ] o.e.j.s.Server Started @23343ms
solr6_1               | 2021-05-04 03:56:23.949 WARN  (Thread-12) [   x:alfresco] o.a.s.c.Config XML parse warning in "solrres:/solrconfig.xml", line 1943, column 88: Include operation failed, reverting to fallback. Resource error reading file as XML (href='solrconfig_insight.xml'). Reason: Can't find resource 'solrconfig_insight.xml' in classpath or '/opt/alfresco-search-services/solrhome/alfresco'
solr6_1               | 2021-05-04 03:56:24.636 WARN  (Thread-12) [   x:alfresco] o.a.s.c.Config You should not use LATEST as luceneMatchVersion property: if you use this setting, and then Solr upgrades to a newer release of Lucene, sizable changes may happen. If precise back compatibility is important then you should instead explicitly specify an actual Lucene version.
solr6_1               | 2021-05-04 03:56:29.745 WARN  (Thread-12) [   x:alfresco] o.a.s.c.SolrResourceLoader Solr loaded a deprecated plugin/analysis class [org.apache.solr.analysis.WordDelimiterFilterFactory]. Please consult documentation how to replace it accordingly.
solr6_1               | 2021-05-04 03:56:29.835 WARN  (Thread-12) [   x:alfresco] o.a.s.c.SolrResourceLoader Solr loaded a deprecated plugin/analysis class [solr.SynonymFilterFactory]. Please consult documentation how to replace it accordingly.
solr6_1               | 2021-05-04 03:56:32.131 WARN  (Thread-12) [   x:alfresco] o.a.s.s.IndexSchema Field content@s____@* is not multivalued and destination for multiple copyFields (4)
solr6_1               | 2021-05-04 03:56:32.131 WARN  (Thread-12) [   x:alfresco] o.a.s.s.IndexSchema Field content@s__lt@* is not multivalued and destination for multiple copyFields (8)
solr6_1               | 2021-05-04 03:56:32.156 WARN  (Thread-12) [   x:alfresco] o.a.s.s.IndexSchema Field text@s__sort@* is not multivalued and destination for multiple copyFields (8)
solr6_1               | 2021-05-04 03:56:32.156 WARN  (Thread-12) [   x:alfresco] o.a.s.s.IndexSchema Field text@s____@* is not multivalued and destination for multiple copyFields (8)
solr6_1               | 2021-05-04 03:56:32.156 WARN  (Thread-12) [   x:alfresco] o.a.s.s.IndexSchema Field content@s__l_@* is not multivalued and destination for multiple copyFields (8)
solr6_1               | 2021-05-04 03:56:32.156 WARN  (Thread-12) [   x:alfresco] o.a.s.s.IndexSchema Field text@s__l_@* is not multivalued and destination for multiple copyFields (16)
solr6_1               | 2021-05-04 03:56:32.168 WARN  (Thread-12) [   x:alfresco] o.a.s.s.IndexSchema Field text@s__lt@* is not multivalued and destination for multiple copyFields (16)
solr6_1               | 2021-05-04 03:56:32.168 WARN  (Thread-12) [   x:alfresco] o.a.s.s.IndexSchema Field text@s___t@* is not multivalued and destination for multiple copyFields (8)
solr6_1               | 2021-05-04 03:56:32.168 WARN  (Thread-12) [   x:alfresco] o.a.s.s.IndexSchema Field content@s___t@* is not multivalued and destination for multiple copyFields (4)
solr6_1               | 2021-05-04 03:56:43.416 WARN  (Thread-12) [   x:alfresco] o.a.s.h.c.ClusteringComponent No default engine for document clustering.
solr6_1               | 2021-05-04 03:56:44.560 WARN  (Thread-12) [   x:alfresco] o.a.s.c.Config XML parse warning in "solrres:/solrconfig.xml", line 1943, column 88: Include operation failed, reverting to fallback. Resource error reading file as XML (href='solrconfig_insight.xml'). Reason: Can't find resource 'solrconfig_insight.xml' in classpath or '/opt/alfresco-search-services/solrhome/archive'
solr6_1               | 2021-05-04 03:56:47.559 WARN  (Thread-12) [   x:alfresco] o.a.s.s.IndexSchema Field content@s____@* is not multivalued and destination for multiple copyFields (4)
solr6_1               | 2021-05-04 03:56:47.560 WARN  (Thread-12) [   x:alfresco] o.a.s.s.IndexSchema Field content@s__lt@* is not multivalued and destination for multiple copyFields (8)
solr6_1               | 2021-05-04 03:56:47.560 WARN  (Thread-12) [   x:alfresco] o.a.s.s.IndexSchema Field text@s__sort@* is not multivalued and destination for multiple copyFields (8)
solr6_1               | 2021-05-04 03:56:47.560 WARN  (Thread-12) [   x:alfresco] o.a.s.s.IndexSchema Field text@s____@* is not multivalued and destination for multiple copyFields (8)
solr6_1               | 2021-05-04 03:56:47.560 WARN  (Thread-12) [   x:alfresco] o.a.s.s.IndexSchema Field content@s__l_@* is not multivalued and destination for multiple copyFields (8)
solr6_1               | 2021-05-04 03:56:47.561 WARN  (Thread-12) [   x:alfresco] o.a.s.s.IndexSchema Field text@s__l_@* is not multivalued and destination for multiple copyFields (16)
solr6_1               | 2021-05-04 03:56:47.561 WARN  (Thread-12) [   x:alfresco] o.a.s.s.IndexSchema Field text@s__lt@* is not multivalued and destination for multiple copyFields (16)
solr6_1               | 2021-05-04 03:56:47.561 WARN  (Thread-12) [   x:alfresco] o.a.s.s.IndexSchema Field text@s___t@* is not multivalued and destination for multiple copyFields (8)
solr6_1               | 2021-05-04 03:56:47.561 WARN  (Thread-12) [   x:alfresco] o.a.s.s.IndexSchema Field content@s___t@* is not multivalued and destination for multiple copyFields (4)
solr6_1               | 2021-05-04 03:56:49.463 WARN  (Thread-12) [   x:alfresco] o.a.s.h.c.ClusteringComponent No default engine for document clustering.

 

cristinamr
Intermediate II

Re: Buscador no muestra resultados

En un principio son WARN, si fuera acompañados de un ERROR sí tendríamos el chivato del problema.

¿Has probado a hacer una reindexación completa?

--
Check our products: AQuA : https://aqua.venzia.es | Seidoc : https://seidoc.es
rcortesr
Active Member II

Re: Buscador no muestra resultados

Sí, he reindexado varias veces pero no se soluciona el problema. También he generado un informe de los índices y no aparece ningún error de indexación. Lo más curioso es que si hago búsquedas en solr directamente funciona bien pero desde el Sahre no hay manera...

angelborroy
Alfresco Employee

Re: Buscador no muestra resultados

Parece que deberías revisar la conexión entre Alfresco y Solr en alfresco-global.properties. Quizá no estén llegando las peticiones.

  index.subsystem.name=localhost
  solr.secureComms=http
  solr.port=8983

 

Software Engineer in Alfresco Search Team.