Error de inicialización de contexto al desinstalar alfresco-esign-cert 1.5.2

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Established Member

Error de inicialización de contexto al desinstalar alfresco-esign-cert 1.5.2

Jump to solution

Buenas tardes, 

estamos teniendo problemas al desinstalar el modulo indicado en un 201605 GA (5.1.0). Es una instalación que usamos para testeos de modelos y algunos desarrollos de javascript por lo que no es crítico. Pero cierto es que nos preocupa que estos problemas se reproduzcan si llega el caso de tener que hacerlo en alguna instalación en producción donde si se esté usando.

En concreto alfresco.log nos arroja lo siguiente:

ERROR [org.springframework.web.context.ContextLoader] [localhost-startStop-1] Context initialization failed java.lang.NoClassDefFoundError: com/itextpdf/text/DocumentException

....

Caused by: java.lang.ClassNotFoundException: com.itextpdf.text.DocumentException

Y ahí se queda.

Parece estar relacionado con el componente itextpdf-5.0.6.jar y/o dependencias en pom.xml según hemos averiguado.

Nos resulta extraño que sea problema de dependencias porque se instaló la release correspondiente descargada del repositorio GitHub de Keensoft (por cierto, muchas gracias). 

Desde entonces hasta ahora, no se ha instalado ni modificado nada en esta instalación que pueda tener relación. Como indicaba antes, la usamos para probar modelos y probar javascript.

También ocurre si intentamos hacer un update del módulo a las versiones 1.6.2, 1.7.2 y 1.8.2. que según se indica en todas "although it runs in Alfresco 5.1.x".

Podríamos configurar que no se desplegara la parte Share cambiando a false el autodeploy en la extensión xml del módulo Share como solución temporal, pero seguiría la parte Repo y nos gusta que las instalaciones queden lo mas limpias posible, aunque sean de pruebas. Pero es que además, sorprendentemente, aun indicando autodeploy false sigue desplegandose.

De ahí que nos animemos a solicitar vuestra ayuda, porque seguro que hay algo que estamos obviando en este caso.

¿Alguna pista de por donde podriamos seguir?

Gracias por adelantado.

 

1 Solution

Accepted Solutions
Highlighted
Alfresco Employee

Re: Error de inicialización de contexto al desinstalar alfresco-esign-cert 1.5.2

Jump to solution

Si tenéis los AMPs/JARs de todos los módulos que necesitáis desplegar, lo más rápido es usar el alfresco.war / share.war que viene con la distribución y aplicarlos sobre esos WARs originales.

 

Software Engineer in Alfresco Search Team.

View solution in original post

2 Replies
Highlighted
Alfresco Employee

Re: Error de inicialización de contexto al desinstalar alfresco-esign-cert 1.5.2

Jump to solution

Si tenéis los AMPs/JARs de todos los módulos que necesitáis desplegar, lo más rápido es usar el alfresco.war / share.war que viene con la distribución y aplicarlos sobre esos WARs originales.

 

Software Engineer in Alfresco Search Team.

View solution in original post

Established Member

Re: Error de inicialización de contexto al desinstalar alfresco-esign-cert 1.5.2

Jump to solution

Hola Angel y gracias por contestar.

Pues simple solución que aunque no nos dice por qué falla, al menos nos quita el problema de encima rápidamente en esta instalación. No lo habíamos visto así. 

Seguiremos probando y revisando para intentar averiguar el origen del problema y posibles soluciones que comentaremos aqui si lo conseguimos.

Muchas gracias.