Problema definiendo custom content model: no detecta dependencias entre más de un fichero de modelo

cancel
Showing results for 
Search instead for 
Did you mean: 
creverte
Active Member II

Problema definiendo custom content model: no detecta dependencias entre más de un fichero de modelo

Buenos días, comunidad.

Estoy teniendo problemas al crear el modelo de contenidos para un proyecto. Lo he separado en partes por temática, un xml de modelo por cada una. Una parte extiende (empleando aspectos) cmSmiley Tongueerson, concretamente un aspecto llamado hpeusu:expEmpleado. El segundo hace uso de datalists y un tipo llamado hpel:eleListaTramites (que hereda de dl:dataListItem) incluye además el aspecto hpeusu:expEmpleado como mandatory en la definición del tipo. Bien, el problema está en que falla al tratar de correr el proyecto vía maven, con un error:

"Caused by: org.alfresco.service.cmr.dictionary.DictionaryException: 08140050 d_dictionary.class_definition.mandatory_aspect_not_found - [hpeusu:expEmpleado, hpel:eleListaTramites]" .

En el xml de modelo de las listas ya he incluido la importación:

<!-- Importar Definiciones de Usuario -->
<import uri="http://www.healthpoint.es/model/usuarioEmpleado/1.0" prefix="hpeusu" />

y en el bootstrap-context.xml ya he dejado mi bean:

 <bean id="intranet-platform-jar_dictionaryBootstrap" parent="dictionaryModelBootstrap" depends-on="dictionaryBootstrap">
<property name="models">
<list>
<value>alfresco/module/${project.artifactId}/model/usuarioEmpleado.xml</value>
<value>alfresco/module/${project.artifactId}/model/hpeLists.xml</value>
</list>
</property>
</bean> 

-----------

¿Alguien puede orientarme acerca de qué está fallando? ¿Qué estoy pasando por alto?

Muchas gracias por adelantado, comunidad.

2 Replies
angelborroy
Expert

Re: Problema definiendo custom content model: no detecta dependencias entre más de un fichero de modelo

No veo el error, todo parece correcto.

Si incluyes (adjuntas) los dos XML de modelo quizá pueda probar a desplegarlos para identificar el problema.

Software Engineer in Alfresco Search Team.
creverte
Active Member II

Re: Problema definiendo custom content model: no detecta dependencias entre más de un fichero de modelo

Ángel, perdona la demora... tenía el modelo en varios xml y obvié eso. En cuanto lo metí todo bien juntito, quedó resuelto.

Abochornado me hallo ... 

Muchísimas gracias!!!