Sigue el plugin de Activiti para ecplise sin poder instalarse?????

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
apache
Active Member II

Sigue el plugin de Activiti para ecplise sin poder instalarse?????

He tratado de instalar el pluggin de Activiti BPMN Designer pero me salta el error de librerias perdidas. He activado todas las opciones q brinda eclipse y nada. Hay alguna solucion para este problema????

Es realmente necesaria esta extensión para trabajar flujos de trabajo en Alfresco???, me mudé a otro IDE (intellij IDEA) pero la extensión que tiene para trabajar con Activiti (actiBPM) es muy básica y no hay movimiento de extenderla o mejorarla.

Saludos y gracias de antemano.

8 Replies
cristinamr
Intermediate

Re: Sigue el plugin de Activiti para ecplise sin poder instalarse?????

Buenas. Entiendo que hablas de este plugin Installing Activiti designer | Alfresco Documentation 

¿Podrías chequear que cumples con los requerimientos? Activiti User Guide " If you would like to use the Activiti Designer then you need Eclipse Kepler or Luna. "

Me da que puedan ir por aquí los tiros.

Te dejo un tutorial bastante bueno, por si quieres ojearlo: Creating Custom Advanced Workflows in Alfresco | ECMArchitect | Alfresco Developer Tutorials 

Comentanos.

Un saludo.

apache
Active Member II

Re: Sigue el plugin de Activiti para ecplise sin poder instalarse?????

He descargado casi todos los eclipses (hasta el Oxygen) pero ninguno me

deja instalar de fomra local u online el plugin. Me dice:

Software being installed: Activiti Eclipse BPMN 2.0 Designer

5.18.0.201508100929 (org.activiti.designer.feature.feature.group

5.18.0.201508100929)

Missing requirement: Activiti Eclipse BPMN 2.0 Designer

5.18.0.201508100929 (org.activiti.designer.feature.feature.group

5.18.0.201508100929) requires 'org.eclipse.emf.transaction 1.4.0' but it

could not be found.

Cuando le instalo el emf me sigue dando errores de librerias. Tengo amigos

que ya tienen instalado la libreria y cdo me copian el eclipse con el

pluggin a mí no se me ven las funcionalidades de Activiti.

Me dices q utilice el Eclipse Kepler or Luna, en otros foros dicen que el

Neon y el Indigo los probé todos y nada. Sé que cdo se trata de conectar

busca un archivo llamado context.xml que no se encuentra en el sitio pero

no creo q ese sea el problema. Además, descargue de Github un compilado que

hicieron del pluggin xq y tampoco.

De hecho estoy siguiendo el tutorial que me mandaste hace una semana y

ahora estoy estancado, x la falta de Activiti, mi marco de trabajo se basa

en:

java version "9.0.1"

Java(TM) SE Runtime Environment (build 9.0.1+11)

Java HotSpot(TM) 64-Bit Server VM (build 9.0.1+11, mixed mode)

Apache Maven 3.3.9 (bb52d8502b132ec0a5a3f4c09453c07478323dc5;

2015-11-10T11:41:47-05:00)

Maven home: D:\Maven\bin\..

Java version: 9.0.1, vendor: Oracle Corporation

Java home: C:\Program Files\Java\jdk-9.0.1

Default locale: es_ES, platform encoding: Cp1252

OS name: "windows 10", version: "10.0", arch: "amd64", family: "dos"

Intel Core i3-4170 @3.70GHz 8GB RAM 1333

2018-01-22 11:25 GMT-05:00 cristinamr <community@alfresco.com>:

Alfresco Community

<https://community.alfresco.com/?et=watches.email.thread>

Re: Sigue el plugin de Activiti para ecplise sin poder instalarse?????

reply from Cristina MR

<https://community.alfresco.com/people/cristinamr?et=watches.email.thread>

in Spanish User Group - View the full discussion

<https://community.alfresco.com/message/827280-re-sigue-el-plugin-de-activiti-para-ecplise-sin-poder-instalarse?commentID=827280&et=watches.email.thread#comment-827280>

apache
Active Member II

Re: Sigue el plugin de Activiti para ecplise sin poder instalarse?????

He descargado casi todos los eclipses (hasta el Oxygen) pero ninguno me deja instalar de fomra local u online el plugin. Me dice:

Software being installed: Activiti Eclipse BPMN 2.0 Designer 5.18.0.201508100929 (org.activiti.designer.feature.feature.group 5.18.0.201508100929)
  Missing requirement: Activiti Eclipse BPMN 2.0 Designer 5.18.0.201508100929 (org.activiti.designer.feature.feature.group 5.18.0.201508100929) requires 'org.eclipse.emf.transaction 1.4.0' but it could not be found.
Cuando le instalo el emf me sigue dando errores de librerias. Tengo amigos que ya tienen instalado la libreria y cdo me copian el eclipse con el pluggin a mí no se me ven las funcionalidades de Activiti.
Me dices q utilice el Eclipse Kepler or Luna, en otros foros dicen que el Neon y el Indigo los probé todos y nada. Sé que cdo se trata de conectar busca un archivo llamado context.xml que no se encuentra en el sitio pero no creo q ese sea el problema. Además, descargue de Github un compilado que hicieron del pluggin xq y tampoco.
De hecho estoy siguiendo el tutorial que me mandaste hace una semana y ahora estoy estancado, x la falta de Activiti, mi marco de trabajo se basa en:

java version "9.0.1"
Java(TM) SE Runtime Environment (build 9.0.1+11)
Java HotSpot(TM) 64-Bit Server VM (build 9.0.1+11, mixed mode)

Apache Maven 3.3.9 (bb52d8502b132ec0a5a3f4c09453c07478323dc5; 2015-11-10T11:41:47-05:00)
Maven home: D:\Maven\bin\..
Java version: 9.0.1, vendor: Oracle Corporation
Java home: C:\Program Files\Java\jdk-9.0.1
Default locale: es_ES, platform encoding: Cp1252
OS name: "windows 10", version: "10.0", arch: "amd64", family: "dos"

Intel Core i3-4170 @3.70GHz 8GB RAM 1333

cristinamr
Intermediate

Re: Sigue el plugin de Activiti para ecplise sin poder instalarse?????

¡No desesperes y ten paciencia! Piensa una cosa: Si a ellos les funciona y tu copiándolo no ha funcionado es por algo que tiene tu entorno. A ver si damos con lo que es.

Ojea esto:

Just install emf transaction from here "http://download.eclipse.org/modeling/emf/updates/releases/ before install
form this locaition: http://activiti.org/designer/update/

De este hilo  

¿Lo has probado?

apache
Active Member II

Re: Sigue el plugin de Activiti para ecplise sin poder instalarse?????

Sí lo probé y nada, ahora no se como pero logré instalar el emf y cdo trato

de instalar el pluggin me da el mismo error. No se me ocurre que es lo q

tengo mal y no quiero pensar que es el windows 10

2018-01-22 11:47 GMT-05:00 cristinamr <community@alfresco.com>:

Alfresco Community

<https://community.alfresco.com/?et=watches.email.thread>

Re: Sigue el plugin de Activiti para ecplise sin poder instalarse?????

reply from Cristina MR

<https://community.alfresco.com/people/cristinamr?et=watches.email.thread>

in Spanish User Group - View the full discussion

<https://community.alfresco.com/message/827283-re-sigue-el-plugin-de-activiti-para-ecplise-sin-poder-instalarse?commentID=827283&et=watches.email.thread#comment-827283>

apache
Active Member II

Re: Sigue el plugin de Activiti para ecplise sin poder instalarse?????

Hable con un amigo que lo tiene instalado y me pasó enl eclipse con el pluggin pero cdo lo paso a mi PC no me aparecen las opciones de activiti.

cristinamr
Intermediate

Re: Sigue el plugin de Activiti para ecplise sin poder instalarse?????

Estoy convencida que debe estar en tu entorno porque yo lo he instalado en diversos SO, y no he tenido problemas. Lo siento pero no se me ocurre nada más a excepción de revisar a nivel de SO que la configuración esté correcta (el java path, permisos sobre directorios, etc..).

Un saludo,

Cris.

apache
Active Member II

Re: Sigue el plugin de Activiti para ecplise sin poder instalarse?????

Gracias revisare a ver q puede ser,disculpa las molestias y gracias de

nuevo x toda la ayuda

2018-01-25 11:17 GMT-05:00 cristinamr <community@alfresco.com>:

Alfresco Community

<https://community.alfresco.com/?et=watches.email.thread>

Re: Sigue el plugin de Activiti para ecplise sin poder instalarse?????

reply from Cristina MR

<https://community.alfresco.com/people/cristinamr?et=watches.email.thread>

in Spanish User Group - View the full discussion

<https://community.alfresco.com/message/827455-re-sigue-el-plugin-de-activiti-para-ecplise-sin-poder-instalarse?commentID=827455&et=watches.email.thread#comment-827455>