i have alfresco 4.2 community edition. Does it need to upgrade after some time ?

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

i have alfresco 4.2 community edition. Does it need to upgrade after some time ?

i have alfresco 4.2 community edition. Does it need to upgrade after some time ?

2 Replies
Highlighted
Master

Re: i have alfresco 4.2 community edition. Does it need to upgrade after some time ?

"It" does not need to upgrade. You though may want to upgrade it if you want to keep up-to-date with bugfixes, security-patches and generally current improvements / new features...

Highlighted
Customer

Re: i have alfresco 4.2 community edition. Does it need to upgrade after some time ?

In addition to Axel's comment, with some Alfresco 4.x components you may have issues in modern browsers with Flash's previews, or with Sharepoint VTI module for online edition, for example. If you still use the original Libreoffice version, you may have also problems with transformations of recent MS-Office formats. 

But as Axel noted, you win a lot with Alfresco 5.x: From user point of view you have faceted and live searches, better previewers, improved uploaders, smart folders, model manager, content links, thrashcan cleaner, OOTB support tools... and also from developer/architect point of view you gain with SOLR4/6, new REST APIs, AOS....

Take care that some things are deprecated in Alfresco 5, such as Lucene search subsystem, jBPM, Alfresco Explorer UI, NFS, some old Web Services and APIs....

Regards.

--C.