Icon for Custom Action

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Established Member

Icon for Custom Action

Jump to solution

I have added a custom action link in Document Actions. The link is working fine but I am not able to get the icon for the link.

I have placed ic_publish_48px.png in ../tomcat/shared/classes/alfresco/web-extension/.

In ../tomcat/shared/classes/alfresco/web-extension/share-config-custom.xml file I have added the icon as:

<action id="publish-to-pubs" icon="./ic_publish_48px.png" label="Publish">

How can I get the icon on screen?

1 Solution

Accepted Solutions
Highlighted
Professional

Re: Icon for Custom Action

Jump to solution

Icons go in a directory structure accessible via the web app's document root, not web-extension.

For example, if you are packaging your customizations using the SDK 3.0.0, which you definitely should be doing, you'd place your document library UI action icon files in:

src/main/resources/META-INF/resources/components/documentlibrary/actions

If you cannot use the SDK to package your AMP then try moving your icon to $ALFRESCO_HOME/tomcat/webapps/share/components/documentlibrary/actions.

View solution in original post

3 Replies
Highlighted
Professional

Re: Icon for Custom Action

Jump to solution

Icons go in a directory structure accessible via the web app's document root, not web-extension.

For example, if you are packaging your customizations using the SDK 3.0.0, which you definitely should be doing, you'd place your document library UI action icon files in:

src/main/resources/META-INF/resources/components/documentlibrary/actions

If you cannot use the SDK to package your AMP then try moving your icon to $ALFRESCO_HOME/tomcat/webapps/share/components/documentlibrary/actions.

View solution in original post

Highlighted
Established Member

Re: Icon for Custom Action

Jump to solution

thanks a lot!

Highlighted
Established Member II

Re: Icon for Custom Action

Jump to solution

Hi sorry to reopen this question, i put my icons in:

"/src/main/resources/META-INF/resources/components/documentlibrary/actions/sign-surf-action-16.png"

like said from jeff

And in my extension cotentx at the "/src/main/resources/alfresco/web-extension/site-data/extensions/my-share-amp-actions-extension-modules.xml ", i use this piece of code:

<extension>
    <modules>
        <module>
            <id>MyAction</id>
            <version>${project.version}</version>
            <auto-deploy>true</auto-deploy>
            <configurations>               
                <config evaluator="string-compare" condition="DocumentLibrary">  
                    <toolbar-actions>
                          <action type="action-link" id="sign-surf-action" label="menu.selected-items.signSurfAction" />
                      </toolbar-actions>        
                </config>
                
                <config evaluator="string-compare" condition="DocLibActions">
                    <actions>

                        <!-- or you can use without icon based on the standard  "Name of indicator image should be of following     

                               pattern “{id}-16.png” : <action id="sign-surf-action" type="javascript"
                            label="my.sign.action.signSurfAction.label">

                         -->
                        <action id="sign-surf-action" icon="sign-surf-action" type="javascript"
                            label="it.abd.sign.action.signSurfAction.label">
                            <param name="function">onActionFormDialog</param>
                            <param name="itemKind">action</param>
                            <param name="itemId">signSurfAction</param>
                            <param name="mode">create</param>
                            <param name="destination">{node.nodeRef}</param>
                            <param name="successMessage">my.sign.action.signed.msg.success</param>
                            <param name="failureMessage">my.sign.action.signed.msg.failure</param>
                            <evaluator>my.alfresco.evaluator.isSignable</evaluator>
                            <permissions>
                                <permission allow="true">Write</permission>
                            </permissions>
                        </action>
                    </actions>

                    <actionGroups>
                        <actionGroup id="document-browse">                       
                                <action index="400" id="sign-surf-action" />
                                 <action index="105" id="sign-surf-multiselect-action" />
                        </actionGroup>
                        <actionGroup id="document-details">
                                <action index="400" id="sign-surf-action" />
                                 <action index="105" id="sign-surf-multiselect-action" />
                        </actionGroup>                       
                    </actionGroups>
                </config>
            </configurations>
        </module>
    </modules>
</extension>

I'm stiil having the blank image like in the sakshi image, what i'm doing wrong?

I use the SDK 3.0.0 and the alfresco community 5.2.

Greetiings.