Inherited rules not being applied to all sub-folders

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

Inherited rules not being applied to all sub-folders

Hi All.

I have a very strange issue with inherited rule sets on Alfresco Community 6.0.1

Some new folders are not displaying the "rules" icon when created, even though the folder states it "This folder inherits rules from it's parent" when selecting manage rules on the folder.

All sub-folders in this older display the same issue i.e. not rule icon displayed for the folder but manage rules states that rules are inherited.....

The end result of this is that documents uploaded to these folders are not having the rules run against them that add properties and aspects and then set those values automatically.

I have attached some images to show this an would be very interested in why this would possibly happen...

As you can see the folder in the first image titled "GWB Machine Tools (NZ) Ltd - CL142190"

does not display the rules icon.

However, the second image shows that this folder inherits rules from its parent.

There rules are ALL inherited from a "rule set" applied to the "Clients" folder in the hierarchy and should apply to ALL subfolders under this. As can be seen, other folders do display the rules icon correctly and their content has the rules applied correctly.

Edit:

It seems that adding any sub-folder to a folder with inherited rules does not show the rule icon, does show that the sub-folder inherits rules from it's parent but does not apply the rules to content added to the sub-folder

Regards

Steve

2 Replies
Highlighted
Active Member

Re: Inherited rules not being applied to all sub-folders

may be this link will be helpful for you.

https://bluefishgroup.com/insights/ecm/adding-custom-indicators-to-the-alfresco-share-document-libra...

and also you have to find actual path of image in share for that put other image path which is already exist in your directory.or for ex for action ./src/main/amp/web/components/documentlibrary/actions/image-16.png

Member II

Re: Inherited rules not being applied to all sub-folders

Hi Rekha

I fail to see how this is relevant here ?

This is not about trying to add new icons to folders or content, it's about trying to find out why icons are not applied to existing functionality i.e. "Why does the rules icon not show on sub-folders created within a folder that has inherited rules".

In-fact, it's more than this as the inherited rules are NOT being applied to content added to or modified in the folder either. Even though clicking "Manage rules" on the folder shows it does inherit rules from it's parent.

Steve