Alfresco Community Edition 201707 GA file list

cancel
Showing results for 
Search instead for 
Did you mean: 

Alfresco Community Edition 201707 GA file list

theoutsseeker
Active Member II
2 9 8,409

Alfresco Community 201707 is available for Windows 64 bit, Linux 64 bit, and Mac OS X.

 

For further information, refer to the release notes:Alfresco Community Edition 201707 GA Release Notes      ‌

Complete Installation

 

Windows icon 64-bit Windows Installer (after downloading, follow the simple install instructions for Windows)
(md5: 3d83d07020b75dc26123578c8e9468f9)

Linux icon 64-bit Linux Installer (after downloading, follow the simple install instructions for Linux)
(md5: e903bbdcb3b8a16e48f77dd91276b41d)

 

Mac icon Mac installer (after downloading, follow the simple install instructions for MacIntosh)
(md5: 3a032ff6548865570d7e420dbb30f25e)

 

Maven repository

Alfresco Community 201707 artifacts are available in our Maven repository under the versions.

  • 5.2.g for Alfresco Platform
  • 5.2.f for Alfresco Share.

Check the Alfresco Artifacts Repository page to configure Maven accordingly.

You may also want to check the Maven Alfresco SDK project, which provides archetypes to help you start a project easily.

 

Individual Components and Custom Installs

 

Alfresco

FileDescription
alfresco-community-distribution-201707.zip
(md5: d9e36b1387bee53f1c5976ed2632fe39)
Use this download for manual install. Contains Web Archive (WAR) bundles for the Alfresco repository and Share UI.

This file also contains Module Management tool, JLAN native libraries for windows and Solr4 integration

alfresco-community-file-transfer-receiver-5.2.g.zip
(md5: c6f59b3ba75f7a20c75a1ce783c439f2)
Alfresco File Transfer Receiver
alfresco-wcmqs-5.2.f.zip
(md5: b97e2537ea9bc7da7b6efbe8bb71b679)
Alfresco Web Quick Start -- refer to [Alfresco Web Quick Start documentation].
alfresco-webeditor-5.2.f.zip
(md5: a3b9b6f67153547495bde09a19b7aa1e)
Alfresco Web Editor -- refer to [Alfresco Web Editor documentation].
alfresco-solr4-5.2.g.zip
(md5: 9e3ac9f41a73e93f8dbeacabcb7f7afb)
Alfresco Solr4 Integration version 5.2.g

Records Management 

FileDescription
alfresco-rm-community-2.6.a.zip 
(md5: 76625ae6732951b90f698871bd961ee5)
Alfresco Records Management Community 2.6.a

Solr 6 Integration

FileDescription
alfresco-search-services-1.1.0.zip 
(md5: 83e9653196fdd1bf3077c4685ef0cdd7)
Alfresco Solr6 Integration version 1.1.0

GoogleDocs Integration

FileDescription
alfresco-googledocs-repo-3.0.4-com.amp 
(md5: df0841d85f9b733960627fad85889f6b)
Repository AMP for GoogleDocs integration
alfresco-googledocs-share-3.0.4-com.amp 
(md5: 9bb8f246e807ab2029511504027746d8)
Share AMP for GoogleDocs integration

 

Alfresco Office Services Module

 

This is a free to use proprietary module licensed under the Alfresco Component License.

FileDescription
alfresco-aos-module-1.1.6.zip 
(md5: c0e6bed2d3e499d3edb94f7e57a2b0d2)
Alfresco Office Services module

 

Community Provided Packages

 

These are unofficial packages maintained by members of our open source community. Share your own by commenting on this document.

FileDescriptionFeedback Method
Alfresco Ubuntu Install
9 Comments

‌ Alfresco Search Services link is not working.

theoutsseeker
Active Member II

Thanks for the feedback. It is fixed now.

How can be PDFium / alfresco-pdf-converter installed and configured without using the bundle installer?

Just using this software is enough? 

https://artifacts.alfresco.com/nexus/content/repositories/public/org/alfresco/alfresco-pdf-renderer/...

Is there any alfresco-pdf-renderer release recommended to use with 201707?

darkredd
Active Member II

Hi Angel,

This might be a late reply, but this link is useful:

 

Though you need to make sure the renderer file has execute permissions.

Thanks, I'll finally manage to configure alfresco-pdf-renderer program. Just download from Alfresco artifacts, install on native OS and configure parameter in alfresco-global.properties. And it looks like 1.0 is the right release for 201707. 

However, , IMO this artefact must be included in this list as an official deliverable.

resplin
Intermediate

There is only one release of alfresco-pdf-renderer. As described in the release notes, it is a very thin wrapper around PDFium, and we would be surprised if it ever has another release. We didn't include it in the list of components because we see it as a part of the Chromium library similar and are treating it the same as Tika or any other library we include. But if people think we should treat it differently, we are open to that.

Richard Esplin‌ in my opinion alfresco-pdf-renderer is radically different to Apache Tika. 

Apache Tika is included with the release, as JAR libraries located at WEB-INF/lib folder in alfresco.war web app. So there is no doubt about version and there is no need to other external download.

You have to download alfresco-pdf-renderer install wizard from the repository, install it as a local program on the Alfresco server and include a property in alfresco-global.properties. I'm very surprised that this can be considered "similar" to Apache Tika.

In any case, if you are not willing to provide this kind of information, I'll write a short blog post trying to help the many people who is going to be lost in the next months. 

BTW, there are 10 different release for alfresco-pdf-renderer in the repository: Index of /repositories/public/org/alfresco/alfresco-pdf-renderer 

Thanks for your time.

resplin
Intermediate

I think I figured out the misunderstanding. It appears that we made a mistake and alfresco-pdf-renderer is not included in the distribution.zip in this release. It is automatically installed by the installers.

I'll list this as a known issue in the release notes, and it will be included in the distribution.zip in future releases.

The nexus artifact repository shows multiple releases for alfresco-pdf-renderer, but the 1.0 release is the one tested for distribution. Installation steps are documented here: Installing alfresco-pdf-renderer | Alfresco Documentation 

If you think additional clarification on this topic is warranted, it would be great if you create a document in this space with the information you think is valuable. That will help us to clearly understand the gaps.

As usual, thanks for bringing this to my attention.

Important notice for installer users at