Añadir usuarios a un site

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member

Añadir usuarios a un site

Buen día. Añadí nuevas cuentas de usuario en Alfresco Community, pero al momento de querer añadirlos a un site no los encuentro ni siquiera escribiendo el nombre completo de la cuenta o del usuario, solo muestra el mensaje "no user found".

Estas nuevas cuentas las cree con la cuenta de administrator.

De antemano gracias por la atención y ojalá me puedan ayudar.

6 Replies
Highlighted
Alfresco Employee

Re: Añadir usuarios a un site

Las búsquedas de usuario se realizan mediante SOLR.

Si estás usando SOLR 6 posiblemente estés afectado por este problema: https://github.com/keensoft/alf-21940-repo

O es posible que tus índices de búsqueda no estén funcionando bien y tengas que re-indexar.

Software Engineer in Alfresco Search Team.
Highlighted
Active Member

Re: Añadir usuarios a un site

Buen día.

Gracias por reponder, en las carpetas del sistema veo que usa SOLR4.

Y referente a la indexación, ¿cómo la hago?

Highlighted
Alfresco Employee

Re: Añadir usuarios a un site

Tienes instrucciones para re-indexar el contenido aquí:

Performing a full reindex with Solr | Alfresco Documentation 

Software Engineer in Alfresco Search Team.
Highlighted
Active Member

Re: Añadir usuarios a un site

Buen día.

Ayer en la noche realice lo de reindexar, sigue el mismo comportamiento y más, antes por lo menos al tratar de añadir usuarios me mostraba los que ya estaban, ahora ni esos ni los nuevos que cree, hace un proceso de buscar y después de un rato se detiene y no muestra ni error.

Para el reindexado detuve alfresco, y borre lo siguiente:

en la ruta /opt/alfresco-community/alf_data/solr4/index/workspace/SpacesStore/   borré la carpeta index

en la ruta /opt/alfresco-community/alf_data/solr4/index/archive/SpacesStore         borré la carpeta index

en la ruta /opt/alfresco-community/alf_data/solr4/model    borré el contenido

en la ruta /opt/alfresco-community/alf_data/solr4/content   borré el contenido

Después reinicie alfresco

Para monitorear no encontré el archivo solr.log en la rura /opt/alfresco-community/tomcat/logs

Al entrar a alfresco en el dashboard, en el espacio que dice "Que he modificado recientemente" aparece un mensaje de "Error al cargar elementos".

Te pido de favor me expliques si ves que hice algo mal o algo me falto, puedo hacer un rolback al día de ayer y volver a empezar.

De antemano gracias.

Highlighted
Alfresco Employee

Re: Añadir usuarios a un site

Los índices de SOLR siempre pueden ser regenerados, no hace falta rollback.

1 - Para Alfresco

2 - Elimina todos los contenidos de la carpeta /opt/alfresco-community/alf_data/solr4 (debe quedar vacía)

3 - Arranca Alfresco

El proceso de re-indexación tardará un rato, pero después deberías poder encontrar todos los contenidos.

Revisa también el fichero catalina.out por si estuviese produciéndose algún error.

Software Engineer in Alfresco Search Team.
Active Member

Re: Añadir usuarios a un site

Excelente, todo resuelto con esta última solución.

Te agradezco muchísimo el apoyo que siempre me brindas.

Saludos.