AAAR Installation Issue

Showing results for 
Search instead for 
Did you mean: 
Member II

AAAR Installation Issue

Hi Francesco Corti


I am trying to setup AAAR with Alfresco and facing issues.


The current setup is


Alfresco CE 201701GA / 5.2

AAAR 4.5

Pentaho DI 7

Pentaho BA 7


During the AAAR installation phase I faced issues


The error shown was the following in catalina.out

2017/02/13 17:04:17 - Restore AAAR_Kettle - ERROR (version, build 1 from 2016-11-05 15.35.36 by buildguy) : We can not find file [file:///opt/pentaho-server/pentaho-solutions/system/AAAR/endpoints/kettle/src/Alfresco_5_2/PostgreSql/AAAR_Kettle_v6.sql]!


There is no "AAAR_Kettle_v6.sql" in that directory but "AAAR_Kettle_v7.sql" is present

I believe this is due to the setting in the following file "kettleVersion"


Also I noticed that inspite of me saving the settings from the pentaho console, during the AAAR installation my settings were getting changed to the default values like FTP port 1121 etc. When I monitored the file, when I skipped from "Alfresco" to "AAAR DataMart" to Pentaho Data Integration (kettle)" tabs in "Configure" section the file values were getting reverted back and finally when I installed the AAAR the values were not what I had provided.


I entered the values manually in the below file and it was taken by the install


Finally to get the install script working I had to create a symlink between "AAAR_Kettle_v6.sql" and "AAAR_Kettle_v7.sql" 


I hope that doesn't mess the installation - but you need to definitely have a look at the mentioned issues


[root@N-alfresco pentaho-server]# cat /opt/pentaho-server/pentaho-solutions/system/AAAR/endpoints/kettle/conf/AAARConfiguration.xml
<?xml version='1.0' encoding='UTF-8'?>
<parameter name="AAARGetAudit" value="true" />
<parameter name="AAARGetNodes" value="true" />
<parameter name="AAARGetWorkflows" value="true" />
<parameter name="alfrescoAuditLimit" value="50000" />
<parameter name="alfrescoNodeLimit" value="50000" />
<parameter name="alfrescoFtpPath" value="alfresco" />
<parameter name="alfrescoFtpPort" value="21" />
<parameter name="alfrescoHost" value="" />
<parameter name="alfrescoLogin" value="admin" />
<parameter name="alfrescoPassword" value="Alfresco!@#$" />
<parameter name="alfrescoProtocol" value="http" />
<parameter name="alfrescoPort" value="8080" />
<parameter name="alfrescoType" value="Alfresco_5_2" />
<parameter name="databaseBin" value="/usr/bin" />
<parameter name="databaseType" value="PostgreSql" />
<parameter name="databaseHost" value="localhost" />
<parameter name="databaseLogin" value="postgres" />
<parameter name="databasePassword" value="Alfresco!@#$" />
<parameter name="databasePort" value="5432" />
<parameter name="databaseSchemaAAAR" value="AAAR_DataMart" />
<parameter name="databaseSchemaKettle" value="AAAR_Kettle" />
<parameter name="databaseSchemaMain" value="postgres" />
<parameter name="kettlePath" value="/opt/data-integration" />
<parameter name="kettleVersion" value="6" />
<parameter name="pentahoAAARPath" value="/public/AAAR" />


So once the AAAR installation is done I am currently facing issues with the script


Before that could you please confirm if everything looks ok to you till now?!!!


I have attached the catalina.out logs produced during the AAAR installation for your perusal.

6 Replies
Alfresco Employee

Re: AAAR Installation Issue

Hi Bushniel Ashraf‌,

Mmmm, this seems to be a bug into the installation dashboards.

My suggestion is to rename "AAAR_Kettle_v7.sql" into "AAAR_Kettle_v6.sql" and you issue will disappear.

The issue affects the installation task only and not the correct setup of the environment.

I hope this will help you.

PS: I'm completing the Alflytics 5.0 (Alflytics is the new name of the AAAR module) and this kind of error will be naturally solved with a different (and easier) approach, so I don't plan to open an issue on github for this.

Active Member II

Re: AAAR Installation Issue

Got the same issue and did the same thing. Issue solved. Installation went well with no apparent errors. But now I am trying to solve Extraction issues...Smiley Sad

Alfresco Employee

Re: AAAR Installation Issue

Hi Jeremie,

Feel free to share the log messages with the error, if needed. ;-)

Active Member II

Re: AAAR Installation Issue

I just messed up the connections. Trying to get myself out. I used Spoon to troubleshoot. Now I'm having Source ID 0 error on Retrieving Source ID task. Need to find out what I setup wrong. Its fun to find the answer yourself. If I'm really really stuck I'll call for help hehe, thanks!

Active Member II

Re: AAAR Installation Issue

Was using my home connection and forgot to add the address to the mysql database of Alfresco duh...issue

Alfresco Employee

Re: AAAR Installation Issue

Good job, nice to hear it.