How to disable Tracking Logo in Community Edition 201901 GA (Docker)

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
r_aurelian
Active Member II

How to disable Tracking Logo in Community Edition 201901 GA (Docker)

Hello!

I have installed Alfresco Community Edition 201901 GA (via Docker) and are serving it over SSL using HAproxy reverse proxy. However, my page does not show as secure - the browser complains I have insecure content on my page. The culprit is "http://www.alfresco.com/assets/images/logos/community-5.2-share.png" which is being loaded, but I do not know by what.

 

How can I disable this? I would not mind the tracking, but the problem is that it`s preventing me from having the page shown as secure.

Setting heartbeat.enabled=false does not have any effect.

Can anyone help?

14 Replies
r_aurelian
Active Member II

Re: How to disable Tracking Logo in Community Edition 201901 GA (Docker)

Again, I do not need it to be necessarily disabled - just to make it request https. If that is not possible, then yes, it would be OK to disable it to make sure all of the content served by the reverse proxy is secured (and this is the only insecure link).

Any ideas?

douglascrp
Advanced II

Re: How to disable Tracking Logo in Community Edition 201901 GA (Docker)

I know about this old blog post on the topic Removing the Tracking Image from Alfresco 

But I don't know if it still aplies for the version you are using.

If not, I think the only thing you need to know is to adapt it.

r_aurelian
Active Member II

Re: How to disable Tracking Logo in Community Edition 201901 GA (Docker)

Thanks Douglas, but I have seen that blog post. However, it`s very old and it references another link (www.alfresco.com/assets/images/logos/community-4.0-share.png) instead of what I am seeing. Also, on the GitHub page of the Tracking Removal project, it is mentioned that it has only been tested with these versions: Alfresco 4.2b/4.2c as well as 5.0/5.1 community. Remember that this was also before Docker.

Is there really no file that I can modify to at least get the tracking image to be requested via HTTPS and not HTTP?

douglascrp
Advanced II

Re: How to disable Tracking Logo in Community Edition 201901 GA (Docker)

Hello.

Well, you came to the conclusion I mentioned... you will have to use that blog post as an idea, and adapt it to the new version. I really believe you just have to follow the described steps, of course, using the source code for your current version, and check what has been changed.

And about using Docker or not, you will have to create an extension project anyway, using JAR or AMP as the result, and then create your custom image containing the JAR/AMP applied into it.

I wish I had the time to try it out for you, but right now, I have too much on my lap already.

I hope someone else can help you with this.

r_aurelian
Active Member II

Re: How to disable Tracking Logo in Community Edition 201901 GA (Docker)

I think that in the end this is beyond my understanding. 

In the end, I opened a bug here: [ALF-22090] Tracking Logo in Community Edition 201901 GA (Docker) is hard-coded to HTTP - Alfresco J... 

Hopefully this will be fixed in a future version.

r_aurelian
Active Member II

Re: How to disable Tracking Logo in Community Edition 201901 GA (Docker)

Chrome has announced that it will start blocking mixed content by default, so this issue has just got much more serious.

I really hope that something can be done about this hard-coded HTTP link in the next GA version of Alfresco Community. Does anyone has any new about this?

ykanke
Member II

Re: How to disable Tracking Logo in Community Edition 201901 GA (Docker)

I have this problem too

jbrasil
Active Member

Re: How to disable Tracking Logo in Community Edition 201901 GA (Docker)

Hi r_aurelian,
I have this problem too
Got the solution?
Thanks a lot!
Zé Brasil

joseantonionava
Established Member

Re: How to disable Tracking Logo in Community Edition 201901 GA (Docker)

Hello...

www.alfresco.com/assets/images/logos/community-5.2-share.png is a white pixel that Alfresco uses to track Community installations. More info here... https://hub.alfresco.com/t5/alfresco-content-services-hub/community-edition-usage-tracking/ba-p/2900... 

It gives problems with most browsers since they consider it insecure.

Here a way to solve the problem (a little dirty but it works) on CE 201901GA:

In share.war/WEB-INF/classes/org/alfresco/web/scripts/MessagesWebScript.class, remove the url by editing Constant_Utf8 in the class.

Good luck.