Problem Creating a Rule

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
pedwards99
Active Member II

Problem Creating a Rule

Jump to solution

Hi there,

I'm trying to create a rule in Share that copies a document from one location to another. When I click on the Select button to choose the destination folder, I get the following dialog.

The Path panel never gets populated - it just sits there with the spinning icon.

This is on Alfresco 6.1, but I'm sure I've seen it on previous versions too, just can't remember what the fix was 

Thanks

Paul

1 Solution

Accepted Solutions
pedwards99
Active Member II

Re: Problem Creating a Rule

Jump to solution

Damn it!

Sorry Angel, this looks like its being caused by a stray customisation. We have a custom rule action originally developed against Alfresco 5.0 that hasn't been updated.

Thanks for your pointer's on debugging it.

Paul

View solution in original post

5 Replies

Re: Problem Creating a Rule

Jump to solution

How did you installed that Alfresco 6.1?

Software Engineer in Alfresco Search Team.
pedwards99
Active Member II

Re: Problem Creating a Rule

Jump to solution

Hi Angel,

It was a manual install from the distribution.zip (Alfresco Enterprise) onto CentOS 7

Paul

Re: Problem Creating a Rule

Jump to solution

Can you inspect the web page with Developer Tools?

Have you any proxy in front of the Tomcat?

Software Engineer in Alfresco Search Team.
pedwards99
Active Member II

Re: Problem Creating a Rule

Jump to solution

Hi Angel,

No proxy in front of Tomcat.

I had a look at Dev Tools and its showing an exception

global-folder_6f0b3335d02aec70f02c51c1d46955fe.js:formatted:706 Uncaught TypeError: Alfresco.CommonComponentStyleFilterChain is not a constructor
at Alfresco.module.DoclibGlobalFolder.i [as _buildCustomStyleClass] (global-folder_6f0b3335d02aec70f02c51c1d46955fe.js:formatted:706)
at Alfresco.module.DoclibGlobalFolder.O (global-folder_6f0b3335d02aec70f02c51c1d46955fe.js:formatted:157)
at Object.handleTransactionResponse (yui-common_85fe398e5deaf2958d87495ebd1e083d.js:17)
at yui-common_85fe398e5deaf2958d87495ebd1e083d.js:17

The file it is complaining about is tomcat/webapps/share/modules/documentLibrary/global-folder.js

This section of code (starting at line 1557)

/**
* Gets resource style specified in the {style} configuration that corresponds with matching filter
* from share-documentlibrary-config.xml [CommonComponentStyle][component-style], {browse.folder} component, or null if the filter does not match.
*
* The returned value is used to be set to the treeNode as customCls attribute, used for rendering custom icons in treeView.
* @param p_oData
*/
_buildCustomStyleClass : function DLGF__buildCustomStyleClass(p_oData)
{
var customStyleClass = null;
if (this.options.customFolderStyleConfig)
{
var filterChain = new Alfresco.CommonComponentStyleFilterChain(p_oData,
this.options.customFolderStyleConfig.browse.folder);
customStyleClass = filterChain.createCustomStyle();
}
return customStyleClass;
},

I'll keep digging and update if I find anything.

Paul

pedwards99
Active Member II

Re: Problem Creating a Rule

Jump to solution

Damn it!

Sorry Angel, this looks like its being caused by a stray customisation. We have a custom rule action originally developed against Alfresco 5.0 that hasn't been updated.

Thanks for your pointer's on debugging it.

Paul

View solution in original post