configuration email

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

configuration email

Bonjour,

Je suis un nouvel utilisateur et découvre alfresco 3.4. Sous alfresco share, j'ai réussi a créer un site et j'ai voulu inviter des utilisateurs pour le partager. Mais a chaque fois que je tentais une invitation, j'avais un échec.
Il parait qu'il faut configurer le serveur SMTP en ajoutant:

mail.host=
mail.port=25
mail.username=
mail.password=
mail.from.default=

Le mail.host doit correspondre a mon adresse IP ?
Le port est toujours 25 ?
Le username et le mail de qui que je dois renseigner ?

Finalement,  il faut éditer avec ce code alfresco-global.properties ou repository.properties ? Est-ce que c'est la seule modification qu'il faut apporter ?

Un grand merci!
33 Replies
Highlighted
Active Member II

Re: configuration email

Votre serveur ne dispose pas forcément d'un service SMTP intégré.
http://fr.wikipedia.org/wiki/SMTP

Il faut faire le config dans alfresco-global.properties, avec les identifiants d'un serveur SMTP fonctionnel.

Si vous avez un compte gmail, un exemple ici : http://forums.alfresco.com/fr/viewtopic.php?f=8&t=4955


A noter que vous avez aussi la possibilité de désactiver la fonctionnalité d'envoi de mail lors d'une invitation à rejoindre un site, en configurant dans alfresco-global.properties :
notification.email.siteinvite=false
Highlighted
Member II

Re: configuration email

Bonjour,

Vous pouvez vous rendre sur le wiki :
http://wiki.alfresco.com/wiki/Outbound_E-mail_Configuration

Une discussion avait aussi été lancée par ici :
http://forums.alfresco.com/fr/viewtopic.php?f=6&t=4827

Bonne journée
Highlighted
Member II

Re: configuration email

[EDIT] Houla je n'avais pas vu toutes ces réponses entre temps!

Bonjour,

Un ptit tour ici pourra vous aider : http://wiki.alfresco.com/wiki/Outbound_E-mail_Configuration.
mail.host : nom du serveur SMPT à partir duquel vous allez envoyer vos emails. Il sera par exemple de la forme smtp.maboite.com.
mail.port : 25, c'est en général le port réservé oui.
Username & Password sont vos id sur le SMTP si vous devez vous authentifier pour envoyer des mails. Il est parfois possible de le laisser vide et de se connecter en anonyme.

Il est préférable d'éditer le fichier alfresoco-global.properties. En effet, ce dernier va "over-writer" toutes les autres propriétés définies dans les autres fichiers. Et c'est plus facile à maintenir.

Bonne journée.
Highlighted
Member II

Re: configuration email

En essayant avec la configuration GMAIL ça ne fonctionne pas chez moi.

Mon fichier C:\Alfresco\tomcat\shared\classes\alfresco-global.properties :

###############################
## Common Alfresco Properties #
###############################

dir.root=C:/Alfresco/alf_data

web.application.context.url=http://127.0.0.1:8080/alfresco

### database connection properties ###
db.driver=net.sourceforge.jtds.jdbc.Driver
db.username=sa
db.password=********
db.name=alfresco
db.host=localhost
db.port=1433
db.url=jdbc:jtds:sqlserver://{db.host}:${db.port}/${dbname}
db.txn.isolation=4096

### FTP Server Configuration ###
ftp.enabled=true
ftp.port=21
ftp.ipv6.enabled=false

### RMI service ports ###
alfresco.rmi.services.port=50500
avm.rmi.service.port=0
avmsync.rmi.service.port=0
attribute.rmi.service.port=0
authentication.rmi.service.port=0
repo.rmi.service.port=0
action.rmi.service.port=0
deployment.rmi.service.port=0

### External executable locations ###
ooo.exe=C:/Alfresco/openoffice/App/openoffice/program/soffice.exe
ooo.enabled=false
img.root=C:/Alfresco/imagemagick
img.dyn=${img.root}/lib
img.exe=${img.root}/convert
swf.exe=C:/Alfresco/swftools/pdf2swf.exe
jodconverter.enabled=true
jodconverter.officeHome=C:/Alfresco/openoffice/App/openoffice
jodconverter.portNumbers=8101

### Initial admin password ###
alfresco_user_store.adminpassword=209c6174da490caeb422f3fa5a7ae634

### Configuration SMTP ###
mail.host=smtp.gmail.com
mail.port=465
mail.protocol=smtps
mail.username=monnom@gmail.com
mail.from.default=monnom@gmail.com
mail.password=*********
mail.smtps.starttls.enable=true
mail.smtps.auth=true
mail.encoding=UTF-8

Contenu de C:/Alfresco/Tomcat/classes/alfresco/extension/custom-email-context.xml

<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE beans PUBLIC '-//SPRING//DTD BEAN//EN' 'http://www.springframework.org/dtd/spring-beans.dtd'>

<beans>
<!–                        –>
<!– MAIL SERVICE           –>
<!–                        –>

<bean id="mailService" class="org.springframework.mail.javamail.JavaMailSenderImpl">
    <property name="host">
        <value>${mail.host}</value>
    </property>
    <property name="port">
        <value>${mail.port}</value>
    </property>
    <property name="protocol">
        <value>${mail.protocol}</value>
    </property>
    <property name="username">
        <value>${mail.username}</value>
    </property>
    <property name="password">
        <value>${mail.password}</value>
    </property>
    <property name="defaultEncoding">
        <value>${mail.encoding}</value>
    </property>
    <property name="javaMailProperties">
        <props>
            <prop key="mail.smtps.auth">${mail.smtps.auth}</prop>
            <prop key="mail.smtps.starttls.enable">${mail.smtps.starttls.enable}</prop>
        </props>
    </property>
</bean>
</beans>
Highlighted
Member II

Re: configuration email

Il faut rajouter l'encodage très certainement :
mail.encoding=UTF-8

Bonne journée
Highlighted
Member II

Re: configuration email

Effectivement j'avais omis d'ajouter l'encodage, mais après ajout ça ne fonctionne toujours pas.

J'exécute virtual_stop.bat et virtual_start.bat pour relancer alfresco, est-ce suffisant ?

Merci d'avance.
Highlighted
Member II

Re: configuration email

Bonjour,

J'ai donc essayé de faire une configuration gmail mais ça ne marche pas.

Mon fichier de config C:\Alfresco\tomcat\shared\classes\alfresco-global.properties

Et j'ajoute au fichier le code suivant:

mail.host=smtp.gmail.com
mail.port=465
mail.username=ziad.hak@gmail.com 
mail.password=****** 
mail.smtps.starttls.enable=true
mail.smtps.auth=true
mail.encoding=UTF-8
mail.from.default=ziad.hak@gmail.com

Et j'ai bien rajouté 'mail.encoding=UTF-8' qui n’était pas précisé dans l'exemple.

J'ai toujours un échec lors d'une invitation.

Est-ce que vous avez une solution ?

Merci!!
Highlighted
Member II

Re: configuration email

Ça doit venir du protocole, essaye ça :

mail.protocol=smtps
Highlighted
Active Member II

Re: configuration email

Et n'oubliez pas de coller ici les logs, quand vous rencontrez un problème.